Samba shared folder is not visible

Discussion in 'Acronis True Image Product Line' started by noib, Jul 11, 2006.

Thread Status:
Not open for further replies.
  1. noib

    noib Registered Member

    Joined:
    Apr 18, 2006
    Posts:
    5
    Hello,

    I have a Samba server running under linux, where i store my image, and that works well if the folder is fully public.
    But, if i want to restrict the access to my client computer's IP, Acronis does not see anymore the network shared folder.. I'm using the bootable Acronis CD. The same computer, under Windows, does see this folder..

    Here are the bare figures and stuff, if that can help :
    Server : Linux (Fedora Core 5, kernel 2.6.15-1) with samba (3.0.21b-2), IP address 192.168.0.101.
    Client : Acronis b3677, with bootable CD, IP address 192.168.0.1.

    Samba config file :
    [acronisTest1]
    comment = This folder is seen by Acronis bootable CD
    browseable = yes
    path = /fast/acronisTest1
    writable = no
    public = yes

    [acronisTest2]
    comment = This folder is NOT seen by Acronis bootable CD
    browseable = yes
    path = /fast/acronisTest2
    writable = no
    public = yes
    hosts allow = 192.168.0.1

    [acronisTest3]
    comment = This folder is NOT seen by Acronis bootable CD
    browseable = yes
    path = /fast/acronis_%I
    public = yes

    %I means client IP address; the client should therefore access the "/fast/acronis_192.168.0.1/" linux directory.

    Of course, those 3 folders are correctly "seen" from the same client with Windows XP.

    Can you help me on this ??
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello noib,

    Thank you for your interest in Acronis Backup Solutions

    Please note, that when you load the product from Acronis Bootable Media it is getting ip address using DHCP. And in most cases it receives ip address, that differs form 192.168.0.1. The most comfortable way to restrict access to your network share is to allow only some users to access it, and use a login\password to authorize.

    Thank you.
    --
    Fedor Kurbatov.
     
  3. noib

    noib Registered Member

    Joined:
    Apr 18, 2006
    Posts:
    5
    Hello,

    The login/password does not suit my case, and i am using DHCP. The DHCP server does set client's IP address to 192.168.0.1.

    After a check, if i type \\server\acronisTest2 manually, acronis does display the network shared folder. But i would like to SEE that shared folder without having to type it.
     
  4. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello noib,

    Thank you for your interest in Acronis True Image

    Please try to add "guest ok = yes" parameter to your Samba config, because initially Acronis True Image is trying to login as guest. So, your new Samba config should be:

    Code:
    [acronisTest2]
    comment = This folder is NOT seen by Acronis bootable CD
    browseable = yes
    path = /fast/acronisTest2
    writable = no
    public = yes
    guest ok = yes
    hosts allow = 192.168.0.1
    
    [acronisTest3]
    comment = This folder is NOT seen by Acronis bootable CD
    browseable = yes
    path = /fast/acronis_%I
    public = yes
    guest ok = yes
    
    After you made the changes in your Samba config please restart it:
    Code:
    # /etc/init.d/smb restart
    Thank you.
    --
    Fedor Kurbatov
     
  5. noib

    noib Registered Member

    Joined:
    Apr 18, 2006
    Posts:
    5
    Hello,

    it still does not work. I changed the guest samba user to "guest":
    Code:
      smb.conf  : guest account = guest 
    modified the sharing definition to the following :
    Code:
    [acronisTest2]
      browseable = yes
      path = /fast/acronisTest2
      writable = yes
      public = yes
      hosts allow = 192.168.0.1
      guest ok = yes
    created a guest linux user and chowned the directory to user guest :
    Code:
    adduser guest
    chown -R guest.guest /fast/acronisTest2
    I also tried to access those directories and successfully accessed and created files from Windows; the created files belong to linux user "guest", no problem.
    But the Acronis program still can't see the network folder.
     
  6. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello noib,

    Please note, that it seems to be your local problem. We tryed to reproduce your problem on our FC5 with your config, but in worked correctly.

    Thank you.
    --
    Fedor Kurbatov
     
Thread Status:
Not open for further replies.