Running IFL on UEFI without a Boot Disk

Discussion in 'backup, imaging & disk mgmt' started by Mister X, Oct 2, 2016.

  1. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    So I just need to copy contents from IFL UFD to IFL partition? And that's it?
     
  2. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Yes. Easy. Copy to the Free Space.
     
  3. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Done. Piece of cake hahahahaha

    edit: and now hidden...
     
  4. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Just so I'm clear, did you use IFL to copy the IFL partition to Free Space on your HD. Did you create a partition for IFL before the copy?
     
  5. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    I did create a partition for IFL files called "IFL" (131MB) after "IMAGE" partition.

    I used Windows File Explorer to copy all files from IFL UFD stick to IFL partition, then I hid it.
     
  6. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    I forgot, you will need IFW installed. It's needed later for the script automation.
     
  7. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Okay installing right away...
     
  8. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    That's not what I did. Let's see if it works. If not we can fix it.
     
  9. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    When I run IFW v3.02 on Windows 10 Home x64 it shows:

    Either way, by running it as or double click it brings up that warning... dang!
    Drive D: (DATA) has full permissions. Only drive C: as usual it doesn't has full permissions by default.
     
  10. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Boot order:
    Windows Boot Manager Status: Normal
     
  11. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Try this, right click imagew.exe (and imagew64.exe), Properties, Compatibility tab, put a tick in Run this program as an administrator. OK. etc
     
  12. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    It's not showing the IFL item which will be called UEFI OS (until you change the name).

    Have a look in the BIOS and see if you have UEFI OS in the Boot Option Properties. See if you can add it. If not you will have to delete the IFL partition and do an IFW Copy of the UFD partition (not the drive) to the Free Space. It might not like the Microsoft created partition.
     
  13. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    I did it but it's still not showing, neither in BIOS nor EasyUEFI obviously. Do I have to copy and set it to active or something in IFW options?
     
  14. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Did you delete the old IFL partition? Then Copy to Free Space. No Options need to be selected.
     
  15. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Yes I did. Strange.
    Going to try again once more.
     
  16. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Try this. In EasyUEFI click Create New Entry, Type "Linux or other OS", click on the IFL rectangle to make it go red. File path... Browse to \efi\boot\bootx64.efi OK. Description IFL, OK.
     
  17. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Done. It says: Status > Normal.
     
  18. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    I restarted the machine and now Boot Option is #2 :thumb:
     
  19. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Sorry, what do you see in EasyUEFI Boot order?
     
  20. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    1st: Windows Boot Manager
    2nd: IFL
     
  21. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    I truly believe IFL partition wasn't detected or seen as bootable in BIOS because it wasn't flagged as ACTIVE.
     
  22. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Excellent. Select IFL, click Set/Unset one-time boot. Power, Reboot, Yes.

    You should see a script error in IFL.
     
  23. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    Mine isn't Active.
     
  24. Mister X

    Mister X Registered Member

    Joined:
    Aug 10, 2013
    Posts:
    2,941
    Location:
    Mexico
    Neither mine Brian, sorry if I said it wasn't. It's still inactive but just saying my BIOS wasn't able to detect due to the lack of active status. Well I go back on topic LOL
     
  25. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    9,233
    Location:
    NSW, Australia
    OK, Post #47
     
Loading...