Returnil Error, Protection always on

Discussion in 'sandboxing & virtualization' started by jrmhng, Nov 4, 2007.

Thread Status:
Not open for further replies.
  1. jrmhng

    jrmhng Registered Member

    Joined:
    Nov 4, 2007
    Posts:
    1,268
    Location:
    Australia
    Hi All,

    Ive installed Returnil and it worked as advertised for a few reboots until it started to turn on automatically on at every reboot. It loads at startup and just turns protection on. I just cant make any changed to the computer. Even after trying to turn it off in the main window, it still turned on automatically. I had to boot into safe mode to uninstall it. Has anyone encountered the same bug?

    Thanks in advance,
    Jeremy
     
  2. screamer

    screamer Registered Member

    Joined:
    Apr 14, 2006
    Posts:
    921
    Location:
    Big Apple USA
    Yeah, I had the same issue. I had to use ShadowDefender instead of Returnil.
    The only way I was able to turn it off was by booting to safe mode, turn off and then it would be off. That is until I turned it on again.

    Perhaps Coldmoon will see this post and reply. He's the developer of Returnil.

    ...screamer
     
  3. jrmhng

    jrmhng Registered Member

    Joined:
    Nov 4, 2007
    Posts:
    1,268
    Location:
    Australia
    Well it might be useful for me to list some background information on my system.

    I have a ThinkPad R61i. It has Vista Business 32bit installed. Integrated Intel graphics and Intel Pro wireless card (and their respective drivers). Most of the lenovo utilities are also included including the power manager, access connections, rescue and recover etc. Other programs that are notable and install drivers/services include the Mozy back up client, groove 2007, truecrypt,NOD 32 2.7.
     
  4. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hello huangker,
    Did you activate the Protection Scheduler?

    Mike
     
  5. glentrino2duo

    glentrino2duo Registered Member

    Joined:
    May 8, 2006
    Posts:
    310
    It happened on my T60 after it went on standby. After resume, the protection is on. Then every restart, it's always on. I had to restore from a backup.
     
  6. jrmhng

    jrmhng Registered Member

    Joined:
    Nov 4, 2007
    Posts:
    1,268
    Location:
    Australia
    Nope I did not interact with it in anyway before error occured. I tried going to standby and that didnt cause it to turn protection on.

    This bug is quite a show stopper. Apart from booting into safe mode and uninstalling returnil, there needs to be a more robust way to handle these kinds of bugs.
     
  7. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hello,
    Could each of you reporting this export the data from these registry keys to a file and send them to support (at) returnilsoftware.com?

    1)HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rvsystem
    2)HKEY_LOCAL_MACHINE\SYSTEM\Setup

    Thank you in advance for the information

    Mike
     
Thread Status:
Not open for further replies.