Restore produces "NTLDR is missing"

Discussion in 'Paragon Drive Backup Product Line' started by KrisR, May 4, 2010.

Thread Status:
Not open for further replies.
  1. KrisR

    KrisR Registered Member

    Joined:
    May 3, 2010
    Posts:
    2
    I want to back up the system disk (C: drive) of my computer. It is a small 20GB harddisk. I use Paragon Backup & Recovery™, version 10.1, build 9169 (01.12.09 ) Free Edition. The OS is Windows XP SP3.
    Producing the backup copy appears to run fine, no errors reported.
    Then I Restore this backup onto a different 20GB disk. Seems also OK.

    But when I try to boot from this newly restored disk, an error message is produced early in the boot right after POST:
    "NTLDR is missing. Press Ctrl+Alt+Del to restart"

    The same happened when I used V10.0, but not with V9.
    When I check the root directory, the NTLDR file not missing and it is not corrupted. I have also tried setting the HDD Raw option, but same error.

    Any ideas on how to handle this problem?
     
  2. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Check boot.ini on the new HD is pointing the right way.

    It probably needs to reflect the new Disk, e.g.

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP" /fastdetect
     
  3. KrisR

    KrisR Registered Member

    Joined:
    May 3, 2010
    Posts:
    2
    Thank you very much for the reply.
    Indeed the boot.ini is identical on the old and the new boot disk, so presumeably it is incorrect on the new disk.
    But I am at bit at a loss what parameters to set.
    I assume it is the rdisk() that should be changed. It is currently set to rdisk(0). But to what?
    Currently my boot disk is physical disk no. 1. Physical disk 0 is a data disk. The new boot disk I try to create is physical no. 2.

    I have tried setting rdisk(1) and rdisk(2), but no success. Same error appears.
     
  4. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Hi Kris,

    You may be changing the wrong boot.ini.

    If you are booting thru your original HD , you need to add an entry for the restored XP to boot.ini on the original HD. You will then get a boot menu allowing you to choose which XP to boot up.

    For example

    If your original XP is on Disk 1 and the restored XP is on Disk 2, the original boot.ini could be:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS=" Original Windows XP" /fastdetect
    multi(0)disk(0)rdisk(2)partition(1)\WINDOWS=" Restored Windows XP" /fastdetect


    If you want to boot thru the second HD containing the restored version of XP, You need to make Disk2 first in Bios boot order, the restored XP partition also needs to be marked Active.

    Boot.ini on the restored partition could be the same as the one above - allowing the choice to boot the original XP (stiil on Disk1 , but not now first in bios boot order ), or the Restored XP.

    Hope it helps.
     
    Last edited: May 5, 2010
Loading...
Thread Status:
Not open for further replies.