Renewal notice

Discussion in 'Prevx Releases' started by Dark Star 72, Mar 8, 2014.

Thread Status:
Not open for further replies.
  1. Dark Star 72

    Dark Star 72 Registered Member

    Joined:
    May 27, 2007
    Posts:
    703
    Switched the computer on this morning and got a pop-up to inform me that my licence expires in 30 days. Fine, but the sys tray icon is now grey with a exclamation mark on it. Although the GUI (which is now brown?) says I am protected there is no padlock on the icon when I open my browser - if I hover the cursor over the icon it just says "no infections found", "no foreground window is protected" as it usually shows.
    Fair enough to inform the user that the licence is expiring but this is going too far - at least show a proper icon with a lock on it!

    I know I am using a beta licence but that is hardly the point, I assume this applies to any licence.

    So, does the icon stay like this for the next 30 days with no proper indication as to weather I am fully protected or not? I am not impressed :thumbd:
     

    Attached Files:

  2. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
  3. Dark Star 72

    Dark Star 72 Registered Member

    Joined:
    May 27, 2007
    Posts:
    703
    Thanks for the links - I vaguely remembered this happening last year but hadn't had time to search for it.
    It's annoying and disconcerting for an experienced user and I would imagine very confusing for an inexperienced one. What really annoys me though is that it seems they are trying to bully and scare people into renewing their licence early. I have had several very negative experiences with Webroot support over licence issues in the last 12 months and this sort of thing is just what might send me elsewhere. Good though the program may be I have serious ethical issues with their attitude.
     
  4. The Seeker

    The Seeker Registered Member

    Joined:
    Oct 24, 2005
    Posts:
    1,100
    Location:
    Adelaide
    I raised the subject on the Webroot forums; it seems the behaviour is here to stay. I did however place my suggestion on the Ideas Exchange, so there is hope.
     
  5. zfactor

    zfactor Registered Member

    Joined:
    Mar 10, 2005
    Posts:
    6,012
    Location:
    on my zx10-r
    i agree this is one area of webroot i get many complaints from clients. the pop up is fine but then they say they think they are unprotected because the icon turns grey and the gui changes colors and says not fully protected. i wish they would change this. if they have to do it like this then it should only be for like the last maybe 5 days or so. 30 days of telling someone they are not protected is a bit of a bad idea imo. i do hear complaints about this often.
     
  6. Umbra

    Umbra Registered Member

    Joined:
    Feb 10, 2011
    Posts:
    2,157
    Location:
    in a remote land :)
    same here ,they should implement an auto-renewal system for beta-testers to avoid this kind of issues
     
  7. bandaid

    bandaid Registered Member

    Joined:
    Jan 19, 2013
    Posts:
    34
    Location:
    USA
    Is the identity shield lock removed from the W also for the the last thirty days?
     
  8. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,011
    Location:
    Ontario, Canada
    You just don't see it but if you have your Browser open hover over the Tray Icon and it should say: The foregound window is protected by Identity Shield

    TH
     
  9. bandaid

    bandaid Registered Member

    Joined:
    Jan 19, 2013
    Posts:
    34
    Location:
    USA
    Triple Helix,
    Thanks for the quick response. I have learned a lot about WSA thanks to you.
     
  10. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
    It says (on hover over) "No Infections Found", with no indication of browser protection. I've checked 3 browsers, don't use Chrome.

    It should be changed, no question I believe. Please note what zfactor said in post #5.
    It would be more than enough to have this panel in GUI, plus notification pop-up. This, otherwise, becomes no more than persistent nagging of paying customers for the last 30 days. Why change the whole GUI to brown etc?
     

    Attached Files:

  11. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    I agree that the icon can be frustrating, but we do still show the foreground protected message on mouse-over as TH pointed out. 30 days is even sometimes not enough for people to come in and actually renew, and when dealing with the backup product that could cause people to lose access to their data, reminders are helpful to ensure that they actually come by and renew. If it was five days, I'd miss it myself as I often have PCs off for two weeks while traveling.
     
  12. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    These requirements have been driven partly by some of our partner organizations which resell WSA, and we adopted them across our userbase to avoid different user experiences and code paths for everyone.

    That said, there could definitely be room for improvement. I'd suggest sending topics to the Ideas Exchange on the Community so that they're seen by a wider audience.
     
  13. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
    Hi Joe. Thanks, don't know if there's any way to get a screenshot of a mouseover? I've tried IE11, FF (ESR), and Pale Moon.
     
  14. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
    Thanks again Joe...for me it's only the icon is the worst part. And I'm posting in Ideas Exchange also, cheers :)
     
  15. Dark Star 72

    Dark Star 72 Registered Member

    Joined:
    May 27, 2007
    Posts:
    703
    Please read my original post TH - I clearly stated that it simply states "no infections found". It does not say anything about the foreground window being protected. This is what I am complaining about.

    Also see the screen shot in my next post.
     
  16. Dark Star 72

    Dark Star 72 Registered Member

    Joined:
    May 27, 2007
    Posts:
    703
    Not so Joe - see attached screenshot. I also see the exact same pop-up that Dermot7 posted re "Webroot has protected you from 5 threats". That figure appears to have been plucked from thin air as it nowhere near correct in my case.
    If there was a pop-up reminder every 5 days and every day for the last 5 when starting or rebooting the computer that would be fine but I'm afraid i find the icon business unacceptable.
     

    Attached Files:

  17. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
    I agree with most of what you suggest :thumb: but accept that it may be necessary to give some people more time. But I'd guess they probably send out email reminders also. For me, there's a fair bit of the licensing model I disagree with, that's different.
    I'm surprised if many have not contacted Support confused about this.

    I'd suggest: Pop-up expiry notification at every boot-up/reboot during last 30 days, combined with notification panel in the GUI.
    And intensify the notifications (but not every 10 minutes!) during last 10 or 14 days.

    There should be no suggestion to the user that the protection per se, is in any sense diminished, the tray icon should behave and appear as normal as possible, and there's no good reason to change the GUI's colour.
     
  18. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    That sounds like an issue on our side - I'll take a look to see what's causing it and fix the icon issue. Thanks!

    As for the "5 threats"... I'll speak with our marketing team to see where the numbers are coming from. The client software doesn't have control over the end content so there are a few places in the middle where it could go wrong.

    Thanks everyone :thumb:
     
  19. zfactor

    zfactor Registered Member

    Joined:
    Mar 10, 2005
    Posts:
    6,012
    Location:
    on my zx10-r
    joe im saying show the pop up for the 30 days that would be fine and show it in the gui, but dont say your system is at risk and turn off the icon in the taskbar until maybe the last 5-7 days. im not saying to not tell the customer at all till the 5 day mark. but still have a pop up saying its time to renew at the 30 day mark. at maybe at the bottom left in the gui have the same message saying you need to renew. mad maybe once a week have a larger pop up or something like that but please not the "system at risk" stuff that just scares most people and they think something is actually wrong with their actual system.
     
Thread Status:
Not open for further replies.