remove ssh-agent completely from ubuntu

Discussion in 'all things UNIX' started by mack_guy911, Oct 2, 2012.

Thread Status:
Not open for further replies.
  1. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    how to remove or disable SSH-agent completely i dont use ssh at all so how to do this thanks in advance :rolleyes:

    also what are other remote-login options are installed in ubuntu default i want to disable/remove all other as well.
     
  2. chronomatic

    chronomatic Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    1,343
    All that's installed by default is the SSH client (not the server). Thus there is no security issue here.

    But if you really want to remove it:

    Code:
    sudo apt-get purge openssh-client
     
    Last edited: Oct 2, 2012
  3. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    very strange it install ssh-imported ....etc now i removed them completely from sypnatic manager.

    here list smb remote desktop......etc





    thanks very much :D

    2 days ago i have strange chrome look like compiz problem same happen in firefox i guess both browser cant be hacked they show broken screen/green ping color on right click like what happen on compiz error

    i clean all temp form bleachbit i was not using apparmor for chrome that time now i set if from you guys help :D



    so i was worried if my system hacked or what so far its look clean i used rkhunter chkrootkit unhide.......also ssh no process showing ........last i need to check logs i am checking also i tried who command to see users login no one expect my user

    and log dont show any wierd file i didnt see any wierd process running process so anything else :rolleyes:


    thanks again chronomatic for help
     

    Attached Files:

  4. chronomatic

    chronomatic Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    1,343
    In my previpous post I said:

    sudo apt-cache purge openssh-client.

    That should have been:

    sudo apt-get purge openssh-client

    Sorry for any confusion!! It was late when I wrote it and I was half asleep!
     
  5. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    yes no worry i got it i used

    sudo apt-get purge openssh-client

    instead of

    sudo apt-cache purge openssh-client.

    but it install ssh -imported id and ssh-krb5 so i removed them form sypnatic anyways problem solved now thanks again very much also your chrome tutorial for app armor is very very usefull thanks for it as well :))
     
  6. ComputerSaysNo

    ComputerSaysNo Registered Member

    Joined:
    Aug 9, 2012
    Posts:
    1,423

    Thanks for this. Very useful.
     
  7. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Additionally you can of course deny ssh service (port 22) with Gufw.
     
  8. chronomatic

    chronomatic Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    1,343
    Really no need since Ubuntu does not install the ssh-server by default. All it has is the client. The server is what listens (if installed).
     
  9. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
  10. BrandiCandi

    BrandiCandi Guest

    There are no daemons (aka servers) running by default as others said. The default installation includes remote desktop and ssh clients. If you don't want the remote desktop client running that can easily be uninstalled as well. Use synaptic package manager, the software center, or command line.
     
  11. ComputerSaysNo

    ComputerSaysNo Registered Member

    Joined:
    Aug 9, 2012
    Posts:
    1,423
    In terminal how do you remove remote desktop?
     
  12. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    If you have dconf tools pkg. installed you can launch the dconf editor and tick the approriate box or on command line...I think..
    dconf write /desktop/gnome/remote-access/enabled false

    Have never had remote desktop configured so am not really sure.
     
  13. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    remote access is disable by default the package name is Remmina

    http://en.wikipedia.org/wiki/Remmina

    please see my screenshot above you see 3 packages i use sypnatic package manager its

    easy to use just search remote desktop you see all 3 also you can search them one by one from screenshot names
     
  14. BrandiCandi

    BrandiCandi Guest

    I'm in windows right now so I can't check, but the remote desktop package is called rdesktop. If you want to find it in terminal type
    Code:
    dpkg -l | rdesktop*
    That will give you all the associated parts.
     
  15. ComputerSaysNo

    ComputerSaysNo Registered Member

    Joined:
    Aug 9, 2012
    Posts:
    1,423
    I removed it via software center so all good!
     
Loading...
Thread Status:
Not open for further replies.