Recent NOD update make all go crazy?

Discussion in 'ESET NOD32 Antivirus' started by Red Dawn, Feb 10, 2009.

Thread Status:
Not open for further replies.
  1. Red Dawn

    Red Dawn Registered Member

    Joined:
    Jun 28, 2004
    Posts:
    116
    I've had v3.0.684, for well over 4 months and have had no issues, running with BlackSpear settings. I noticed though ekrn.exe go crazy since the past module updates, and I say this because nothing has changed on my laptop, other then windows updates, running Vista. Now when trying to browse the net via firefox, even opening the main window for NOD, cpu spikes for about a min or more at 80 percent or higher. If I download a file via FF, and open the download box to view how my download is going, things freeze up for a good period of time, cpu spiking, due to NOD, then comes back. This never happened before, and I noticed some modules recently updated on v3. Is this happening to others? I've never had issues with Eset before, and I really don't want to start now, any pointers on how to resolve this? Thanks

    oh, and I know it's NOD, because as soon as I disable Realtime, Email, and Web protection, spikes stop, laptop goes back to normal, turn them on, have the spike issues...
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Does the same happen with default settings?
     
  3. Red Dawn

    Red Dawn Registered Member

    Joined:
    Jun 28, 2004
    Posts:
    116
    Yes it does Marcos, tried that, should have pointed that out in my original post. I know it's one of those updated modules, because of the dates shown on their updates, and the issues starting at the same time, with NO changes to my system. When I turn off the settings, basically turn off NOD, no cpu spikes, turn on, and the info I posted starts. I had no issues PRIOR to the update, so I don't know what went wrong. Had a full scan on Sunday, no problems, but this week hasn't been good with NOD sadly. And I had no issues with BlackSpear settings, for over 4 months since upgrading from 2.7, all was great, until now. o_O
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    I assume the problem goes away after disabling real-time protection. In such case, could you please use Filemon or Process monitor from Microsoft to monitor which files are accessed by ekrn.exe? V4 beta also shows the names of files being scanned so it, too, might give you a clue as to what's happening.
     
  5. Red Dawn

    Red Dawn Registered Member

    Joined:
    Jun 28, 2004
    Posts:
    116
    Will do that first thing when I can, and post what I find, thank u... :D
     
  6. Red Dawn

    Red Dawn Registered Member

    Joined:
    Jun 28, 2004
    Posts:
    116
    Well after using Process Monitor for a few days, I think I found the problem. Seems as though NOD was scanning a vista sidebar gadget installer over and over and over, with a BUFFER OVERFLOW tag, and when I removed it from my laptop, all seems fine. Don't really understand what caused it to go crazy on a simple gadget installer, that had no virus, checked it on Virus Total and it was from Live Gallery. Anyway though, my issues seem to be resolved, thanks Marco for the heads up on what to look for...
     
  7. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,856
    What gadget was it? Can you reinstall it and see if you can replicate the behavior?
     
Thread Status:
Not open for further replies.