RAS no longer updating

Discussion in 'Other ESET Home Products' started by Bakker, Jul 29, 2008.

Thread Status:
Not open for further replies.
  1. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    I came into work this morning and i noticed that all the clients in RAS/RAC where highlighted green (thus having a newer version than what was on the RA server).

    It appears that RAS/RAC is no longer updating, all clients are now synced to 3204, eventhough 3205 is out.

    When i check tools->server options it shows Virus Signiature DB: Unknown.

    When i do a manual update via the Updates tab, it sais it fires the update, but nothing seems to happen.

    I've already restarted the RAS services.

    Deleting the contents of the mirror folder and triggering a new update leaves the folder empty (except for the nod32v2 folder and the hosts.txt it creates inside)

    Deleting the contents of C:\Documents and Settings\All Users\Application Data\ESET\ESET Remote Administrator\Server\updfiles and triggering an update only results in new .ver files.

    License shows that it's valid well into 2011

    When i trigger a manual update, the debug log shows:
    Code:
    [2008-07-29 09:48:19.201] V1 [488ecb43004d] [00001070] <SESSION_INFO> ConsoleProcessRequest: 0x00411ac0
    [2008-07-29 09:48:29.591] V1 [488ec89d0000] [00001570] <UPDATER_INFO> Update is not needed.
    [2008-07-29 09:48:29.794] V1 [488ec89d0000] [00001570] <UPDATER_INFO> Nod32v2 mirror created successfully, code : 0
    [2008-07-29 09:48:38.169] V1 [488ecb56004f] [00000930] <SESSION_INFO> KernelProcessRequestInitial: 0x004086c0
    [2008-07-29 09:48:38.357] V1 [488ecb56004f] [00000930] <SESSION_INFO> KernelProcessRequestFull: 0x0040dc40
    And the normal log:
    Code:
    [2008-07-29 09:48:29.263] V3 [488ecb4d004e] [00001570] <UPDATER_INFO> Update started
    [2008-07-29 09:48:29.810] V3 [488ecb4d004e] [00001570] <UPDATER_INFO> Finished, took 547ms
    Does anyone have any idea what's wrong?
     
  2. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    I am seeing this same behavior. RAS 2.0.110 is stuck on the 3304 definitions and refuses to update. The debug log shows the same sequence of

    Code:
    [2008-07-29 09:35:40.263] V1 [488f1c590000] [00000fe0] <UPDATER_INFO> Update is not needed.
    [2008-07-29 09:35:40.810] V1 [488f1cac0015] [00000a18] <SESSION_INFO> KernelProcessRequestInitial: 0x004086b0
    [2008-07-29 09:35:41.107] V1 [488f1cac0015] [00000a18] <SESSION_INFO> KernelProcessRequestFull: 0x0040dc30
    and I can't get anything to update. I don't have a v2 mirror, but that is the only difference between Bakker's issue and mine.
     
  3. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    Okay, I got mine working again. Stop the RAS service and then purge the contents of your mirror and updfiles directories. Restart the service and fire off a manual update. It didn't look like anything was happening at that point but then files began to write to the updfiles\tempmirror directory and after about 5 minutes things were updated to 3306.
     
  4. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    Yeah i tried that before and it fixed it after 10 minutes but now its back to the old situation. Clients now have the 3306 signiature.

    I suspect this has to do with the update issues everyone else is having. It seems like there is nothing else to do but wait. =\
     
  5. edwin3333

    edwin3333 Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    244
    I'm stuck at 3304 and have purged the directories but it still doesn't update.
     
  6. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    The update servers are overloaded and for some reason are defaulting to sending up-to-date confirmations instead of a connection rejected response. Keep manually firing updates and eventually you will get through.
     
  7. Bakker

    Bakker Registered Member

    Joined:
    May 28, 2008
    Posts:
    90
    I have the RAS to update every 60 minutes, it seems to get through sometimes, its upto 3308 now and it was 3306 when i left yesterday. Eventhough RAS is showing that it doesn't know what virus definition it has.

    Really annoying =\
     
  8. duijv023

    duijv023 Registered Member

    Joined:
    Feb 16, 2006
    Posts:
    230
    Location:
    Rijnsburg, Netherlands
Thread Status:
Not open for further replies.