RA Server setup error

Discussion in 'Other ESET Home Products' started by mrnathan2, Nov 30, 2007.

Thread Status:
Not open for further replies.
  1. mrnathan2

    mrnathan2 Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    2
    I am trying unsuccessfully to upgrade the RA Server on one of our servers to the new version 2.0.29.

    Previously, version 1.0.15 was installed.

    The installation process fails with the following message:

    Eset Remote Administrator Server setup ended prematurely because of an error. Your system has not been modified. To install this program at a later time, please run the installation again. You can enable full logging during installation by using msi command line options. View log. Press to view the current temporary log.

    The contents of the log are pasted at the bottom of the post.

    Initially I was trying to upgrade the existing RA Server and Console (both v1.0.15). But in attempting to resolve this I have uninstalled both of them as well as the NOD32 w/ mirror v2.7 which was previously installed and rebooted the system twice. I still get the same error trying to install the new version.

    The file I am installing from is "era_server_nt32_enu.msi".

    I have tried downloading a fresh copy.

    The operating system on the server is Windows Server 2003 Standard Edition w/ Service Pack 2.

    I am using the 'typical installation' option.

    I am using the "nod32.lic" file we received 8/23/07 when we renewed our subscription for another 2 years.

    (Is it possible that this is the problem? Since the license file was issued prior to this version of RA Server becoming available.)


    This is the temporary log file from the installation:

    [2007-11-30 17:11:39] Global setup flag ERA_SETUP_ACTIVE was enabled
    [2007-11-30 17:11:39] Setup exclusive lock <<ENABLED>>
    [2007-11-30 17:11:39] SetupStart: Entered (Initialize)
    [2007-11-30 17:11:39] MSI database: E:\Network Shares\ESET\Installation\era_server_nt32_enu v2.0.29.msi
    [2007-11-30 17:11:39] Installing product: ERA SERVER
    [2007-11-30 17:11:39] Current directory: C:\WINDOWS\system32
    [2007-11-30 17:11:39] Global setup flag ERA_SETUP_PROGRESS was enabled
    [2007-11-30 17:11:39] RetrieveVersionInfo
    [2007-11-30 17:11:39] Cannot open service [ERA_SERVER] (code=1060)
    [2007-11-30 17:11:39] Cannot open service [NOD32RA] (code=1060)
    [2007-11-30 17:11:39] Prior installation of RA server was not found
    [2007-11-30 17:11:39] Cannot detect prior version
    [2007-11-30 17:11:39] Current product version is 2.0.29
    [2007-11-30 17:11:39] CheckOdbc: Entered
    [2007-11-30 17:11:39] MS Access driver is present
    [2007-11-30 17:11:39] RetrieveMsiTexts: Entered
    [2007-11-30 17:11:40] PrepareXmlConfig: Entered
    [2007-11-30 17:11:40] ImportServerConfig
    [2007-11-30 17:11:40] LoadProperties: Entered
    [2007-11-30 17:11:40] LoadPropertiesFromXml: CfgFile=C:\DOCUME~1\ADMINI~3\LOCALS~1\Temp\RADEFCFG.TMP
    [2007-11-30 17:11:40] LoadPropertiesFromXml: CfgFile=C:\DOCUME~1\ADMINI~3\LOCALS~1\Temp\RAXMLCFG.TMP
    [2007-11-30 17:11:43] CheckLicKeyFile: Entered
    [2007-11-30 17:11:45] SelectFile: Entered
    [2007-11-30 17:11:51] SelectFile: E:\Network Shares\ESET\License\nod32.lic
    [2007-11-30 17:11:51] CheckLicKeyFile: Entered
    [2007-11-30 17:11:53] CheckLicKeyFile: Entered
    [2007-11-30 17:11:56] SaveProperties: Entered
    [2007-11-30 17:11:56] Saving properties to "C:\DOCUME~1\ADMINI~3\LOCALS~1\Temp\RAXMLCFG.TMP"
    [2007-11-30 17:11:56] SaveProperties: Done
    [2007-11-30 17:11:57] ExecuteBegin: Entered
    [2007-11-30 17:11:57] UI LEVEL = "5"
    [2007-11-30 17:11:57] COMN DATA = "C:\Documents and Settings\All Users\Application Data\"
    [2007-11-30 17:11:57] APP DIR = "C:\Program Files\ESET\ESET Remote Administrator\Server\"
    [2007-11-30 17:11:57] LogInstallInfo: AppDir=C:\Program Files\ESET\ESET Remote Administrator\Server\
    [2007-11-30 17:11:57] LogInstallInfo: StorageDir=C:\Documents and Settings\All Users\Application Data\ESET\ESET Remote Administrator\Server\storage\
    [2007-11-30 17:11:57] LogInstallInfo: DatabaseDir=C:\Documents and Settings\All Users\Application Data\ESET\ESET Remote Administrator\Server\database\
    [2007-11-30 17:12:18] CopyLicKey: Entered
    [2007-11-30 17:12:19] CreateCfgFiles: Entered
    [2007-11-30 17:12:19] Reading item 'work.xml' from register failed
    [2007-11-30 17:12:19] InstallAbort: Entered
    [2007-11-30 17:12:19] Reading item 'product' from register failed
    [2007-11-30 17:12:19] Cannot determine product type
     
  2. bsilva

    bsilva Registered Member

    Joined:
    Mar 24, 2004
    Posts:
    238
    Location:
    MA, USA
    After you uninstalled it, did you delete the folders and clean the registry?
     
  3. stamatov

    stamatov Registered Member

    Joined:
    Dec 4, 2007
    Posts:
    1
    What registry you talking about, its silly.
    I have same problem on one of our servers (win2003server). exactly the same problem (nearly same log file) and i cant make it work.
    Its just so bad writen softwire, i cant imagine it be worse. Log file is 101% useless, i have 2 linux servers here, use many log files from many programs and i can see everything i need in them.
    Stuped log file from RAS installation dont have any information at all to solve th e problem, and i waste more than 20 hours of my time...
    So if any1 can help me (or us i may say couse many sysadmins i talk to have same problem, and most roll back to old version of software) plz write it, if not plz dont spam thread.

    inj. Martin Stamatov sysadmin 2plus bulgaria
     
  4. bsilva

    bsilva Registered Member

    Joined:
    Mar 24, 2004
    Posts:
    238
    Location:
    MA, USA
    Windows registry under HKEY_Local_Machine remove the eset folder.
     
  5. aaristotle

    aaristotle Registered Member

    Joined:
    Aug 20, 2007
    Posts:
    7
    I have had exactly the same error on the same configuration. Fortunately my testing is on a virtual server simulation of our live environment, so until ESET sort it out our users are not affected. I submitted a case with the details and log files to Eset however I have received absolutely no response.
     
    Last edited: Dec 10, 2007
  6. mrnathan2

    mrnathan2 Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    2
    Do you have good reason to think that that would help?

    I don't remember now if I did that or not, but if it's just a shot in the dark I'm not very inclined to waste hours of my time uninstalling, rebooting, deleting, attempting to install, and finally re-installing the original version, rebooting, and re-configuring all my settings again.

    I did that two weeks ago :p
     
Thread Status:
Not open for further replies.