Push install and force instant update

Discussion in 'Other ESET Home Products' started by briwlls, Mar 31, 2010.

Thread Status:
Not open for further replies.
  1. briwlls

    briwlls Registered Member

    Joined:
    Nov 23, 2005
    Posts:
    25
    We're running ERAS 3.1.15 and ERAC 3.1.15, we have policies setup and when we push install NOD32 4.2.3.5 the client doesn't immediately reflect the policy and doesn't immediately download the latest signature. It appears that it only does this on the first 60 minute "default" update interval.

    Is there a command line or switch we need to add to the push install package to force immediate application of the policy and force the client update?
     
  2. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    Assuming you are bundling in the correct update settings in the installer package (not the policy), the Nod32 will attempt to perform an update right after it is installed.
     
  3. briwlls

    briwlls Registered Member

    Joined:
    Nov 23, 2005
    Posts:
    25
    Thank you, I modified the cfg.xml file attached to the install package, I then modified just enough settings to minimize any confusion for the end-user;

    1: Changed interval between connectons to 0
    2: Notify about missing OS updates to "No updates"
    3: Disabled startup splash screen
    4: Set Display only notifications requiring user intervention to "Yes"
    5: Specified the update server under "My Profile"

    So is it fair to say that once the initial contact is made all the remaining settings specified in the client policy will be inherited?
     
    Last edited: Mar 31, 2010
  4. rockshox

    rockshox Registered Member

    Joined:
    Oct 23, 2009
    Posts:
    261
    That's probably your problem. Change the interval to at least 1, or set it back to 5 which is the default.

    Also, make sure you have the Remote Administrator server setup in your initial config or else the clients will never connect in and pull the policy.

    All my clients I push install, they pull definition updates almost immediately as I have the update server set in the initial config, and they pull the policy at the 5 minute mark every time.
     
Thread Status:
Not open for further replies.