procguard.exe fails to start

Discussion in 'ProcessGuard' started by Maji, Oct 12, 2005.

Thread Status:
Not open for further replies.
  1. Maji

    Maji Guest

    Hi, guys. I am now having a problem with ProcessGuard at startup. The executable procguard.exe fails to start up now, which makes me feel very unsafe. Here is what my system log reported for the error:

    Event Type: Information
    Event Source: Application Popup
    Event Category: None
    Event ID: 26
    Date: 10/12/2005
    Time: 9:59:13 AM
    User: N/A
    Computer: FOIF6AUPOZXS240
    Description:
    Application popup: procguard.exe - Application Error : The instruction at "0x004da9ed" referenced memory at "0x00000000". The memory could not be "written".

    Click on OK to terminate the program

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    This error pops up both at startup and if I try to launch the process manually. Does this mean I will have to reinstall, or is there some way I can fix this? Thanks for your support. :)
     
  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Maji, Are you trying to run PG from an ordinary users accout and what operating system are you running?

    If you are running from a user account the PG gui does not run but alerts will be shown. You can run the GUI from a user account but only using the "Run as" command as an administrator

    Thanks. Pilli
     
  3. Maji

    Maji Guest

    I am running on Windows XP Pro SP2 and I am the administrator. I think the root of the problem is that ProcessGuard is one of the programs out there that fails to work properly if Windows XP's DEP is set to "Always On" in the boot.ini file. I have since changed it back to the original optout setting, since that was the setting PG was working fine with before.

    The same error also occured with Pest Patrol, so this is obviously not an error solely restricted to PG. I should have known better than to try and use that setting when many applications out there simply will not work with DEP fully enabled. Oh well...you live and learn. :)

    Thanks for all of your help, guys.
     
  4. rickontheweb

    rickontheweb Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    129
    I noticed the same thing. You have to leave DEP set at OptOut.

    It doesn't need a listed exception in OptOut mode however. In AlwaysOn mode, even applications with built in DEP OptOut exceptions are ignored and the GUI portion of PG will fail to load.
     
Thread Status:
Not open for further replies.