Processe ekrn.exe Usage

Discussion in 'ESET NOD32 Antivirus' started by HolyWind, Aug 19, 2010.

Thread Status:
Not open for further replies.
  1. HolyWind

    HolyWind Registered Member

    Joined:
    Jan 21, 2006
    Posts:
    17
    I just might be a little paranoid with my new install of NOD32 but when I goto Windows Task Manger and look at my processes. ekrn.exe is running a 60,129 Mem usage all the time. The little NOD icon in the bottom right is green and is not spinning.

    Is this normal and can does anyone mind posting there results?

    Window Xp will all service packs and updates applied.
    Running NOD32 Antivirus 4 ver. 4.2.64.12
    Virus Database Sig: 5380

    Thanks Ladies and Gents.
     
  2. xMarkx

    xMarkx Registered Member

    Joined:
    Dec 1, 2008
    Posts:
    447
    Hello,

    My ekrn.exe is using 52,224 K on Windows Vista SP2 with the latest ESET NOD32 Antivirus 4.2.64.12. I think it's a bit higher on my Windows XP machine.

    Hope this helps you.

    Regards,

    Mark
     
  3. twichert

    twichert Registered Member

    Joined:
    Feb 2, 2010
    Posts:
    14
    Location:
    Lansing, MI
    Perhaps someone from ESET could demystify erkn's resource consumption strategy for us?

    Mine's at 25,904 on WinXP Pro w/ 4.0.474.0 at the moment. It varies a lot though, and best as I can tell it depends on how many file handles and applications I have open. My guess is ekrn.exe scales its resource consumption in anticipation of spikes in file operations. Boxes I have with 4.2.64.12 on them, regardless of operating system and hardware, exhibit what looks to me like a similar pattern.

    There may very well be a major difference between 4.0 and 4.2 in terms of resource consumption behavior, but I haven't looked into it any deeper than passing observations.
     
  4. microbial

    microbial Registered Member

    Joined:
    Aug 26, 2009
    Posts:
    156
    Location:
    UK
    about 52 400 here on Win 7 Ultimate... and that's just web browsing.
     
  5. stevvie

    stevvie Registered Member

    Joined:
    Jul 11, 2008
    Posts:
    51
    Mines at 49,845 but more WORRYINGLY is that ekern.exe is stuck at 49-50% CPU usage (on dual core so thats locked a whole core up) and then wont's allow ANY internet usage.
     
  6. JeremyWW

    JeremyWW Registered Member

    Joined:
    Apr 13, 2005
    Posts:
    237
    Idling @ 32,376K, 0% CPU, blips to 10% on web page refresh. Dual core Athlon 4400+, 2Gb RAM, Win 7 Ult. (32 Bit)

    Maybe you guys should try a complete uninstall / re-install? Just a thought...
     
  7. Banger696

    Banger696 Registered Member

    Joined:
    Sep 6, 2006
    Posts:
    274
    I have just had this on my main XP machine. Hovering over the ESET icon said startup scan running. Thing is it had been running for an hour. Can't repeat it and a reboot stopped it, very strange. Further investigation shows its the update scan after database 5384, would happen on a weekend.
     
    Last edited: Aug 21, 2010
Thread Status:
Not open for further replies.