Problems with Privateinternetaccess VPN

Discussion in 'privacy technology' started by Jarmo P, Jun 25, 2015.

  1. Jarmo P

    Jarmo P Registered Member

    Joined:
    Aug 27, 2005
    Posts:
    1,188
    First I post this without knowing if I am in danger of my security in doing so. To gather possibly some knowledge from existing users. Normally I would not post here of what VPN program I am currently using.

    This is strange program because it does not put any starting icon on the desktop or anywhere I can see. I finally figured out it is pia_manager.exe that needs to be made a shortcut.

    Another difficulty is with security software because rubyw.exe needs to start from AppData/Local/Temp/"somerandomfolder" folder. In AppGuard I had to make pia_manager.exe a power application, damn it. Also before starting PIA VPN, I have to put AG in Medium mode and allow user space launches guarded. After connecting to a VPN server I will then have to remember change AG to Locked Down mode.

    About servers, I don't see these countries: Russia, Turkey, Singapore, Japan, Mexico, Brazil. Not such a biggie for me but I'm wondering.

    I could not connect to a French server.
    If I disconnect from a VPN server, the VPN Killswitch enabled, I can still use internet. So that also does not seem to work

    Originally I installed this on my standard user account. At some point the program stopped connecting to servers, the openvpn.exe would not start. Uninstalled it according to instructions in the page: https://support.privateinternetaccess.com/Knowledgebase/PopularArticles
    The program has no uninstall option!

    Installed to my admin account. Worked there as tested. I then used it on my standard user account and it worked also there. Until it stopped at some point working again. Same as above. Computer reboots did not help.

    I went to admin account and it worked there, logged out and back to standard user, and it works again.

    I guess this is a cheap VPN because of all these problems and inconviniences.
     
Loading...