Problems with Bitcomet

Discussion in 'LnS English Forum' started by pietronik, Jun 18, 2005.

Thread Status:
Not open for further replies.
  1. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
    Hi,
    I'm Italian, so I'm sorry for my bad English.
    I'm a new user of Look'n'stop and I found it really great!
    I use Bitcomet as P2P client and I've configurated it but I can't connect to DHT network. I think that LnS close a port necessary to connect with DHT.
    Can somebody Help me, please!
    Thanks
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
  3. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
    I've already imported that rule but DHT network don't work!
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    What is DHT ? (sorry for my ignorance o_O )

    Do you have some alerts in the Look 'n' Stop logs ?

    Frederic
     
  5. snowbound

    snowbound Retired Moderator

    Joined:
    Feb 18, 2003
    Posts:
    8,723
    Location:
    The Big Smoke
  6. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
    The log gives me a lot of signalation for stateful packet inspection but, also, if I disable SPI, DHT doesn't connect.
    What is the real function of SPI?
     
  7. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
  8. Martin Aston

    Martin Aston Guest

    Bitcomet uses a single port for its connections. I think it is 26472, look it up in the program options (and look in the LnS log to see if the port that Bitcomet needs is being blocked). You'll have to allow this port in LnS in order to make Bitcomet work. That should do the trick.
    Good luck.
     
  9. Martin Aston

    Martin Aston Guest

    Ooops, you were asking about DHT. Forget my previous answer.
     
  10. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    So the problem is not only the TCP SPI (SPI stands for Stateful Packet Inspection, it detects packets that are not belonging to an allowed open connection and drop them).

    After you disabled the TCP SPI, was the log clearer with some other alerts ?

    Frederic
     
  11. zoes

    zoes Registered Member

    Joined:
    Jun 10, 2005
    Posts:
    12
    hi,pietronik

    I think your trouble nothing with LNS.

    I using Bt with DHT,it works well.
     
  12. Name

    Name Guest

    I'm getting the same alerts if I enable SPI WHILE BitComet is running (DHT doesn't matter). If I enable SPI BEFORE starting BitComet everything is working fine.

    Oh well, maybe that's normal...
     
  13. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
    So, if L'n's isn't the problem what I can do to make DHT fully working?
     
  14. Name

    Name Guest

    Like Martin said before, in BitComet goto Options->Preferences->Connection, look up your listening port, make sure it's enabled and add a rule (protocol: "TCP or UDP"(!), "Source / Destination:" "TCP/UDP : port" "Equals" <your port>) in LnS internet filtering. Make sure the rule is somewhere above the "Block all other TCP packets"-rule.

    BTW, the rule posted earlier does not work with BitComet (uses different port).

    Most torrents aren't configured to use the DHT network by default yet. So for now you have to enable DHT manually for almost every task: right click it, Properties->Advanced, check "Enable Public DHT Network".
     
  15. pietronik

    pietronik Registered Member

    Joined:
    Jun 18, 2005
    Posts:
    6
    I've configurated the UDP rule in this way:
     

    Attached Files:

  16. Name

    Name Guest

    Do the following changes:

    IP protocollo: "TCP or UDP"
    TCP/UDP : porta (left side!): uguale a <your port>
    TCP/UDP : porta (right side): tutti

    You only need that one rule for BitComet to function completely.

    Again make sure it's somewhere above the "block all other TCP"-rule.
     
Thread Status:
Not open for further replies.