problems - Vista's drive letter change after restoring

Discussion in 'Acronis True Image Product Line' started by callmecheez, Jun 12, 2008.

Thread Status:
Not open for further replies.
  1. callmecheez

    callmecheez Registered Member

    Joined:
    Jun 12, 2008
    Posts:
    4
    I created an backup image in True Image; it has restored my HD (with 2 partitions; 1 XP the other Vista 64) what looks like correctly.

    However when I boot into Vista 64, my vista drive is D: and my XP is C:.

    All of vista's registry references EVERYTHING as C:\, not D:\. And prior to the restore Vista SAW vista's installation partition as C:\ not D:\.

    I tried booting from the vista CD into command propmt, changed the drive letters round in Diskpart but vista still see's its own drive as D:.

    As such, it doesn't boot properly, lots of errors before desktop and has to boot to a 'temp' profile.


    Any help / advice / suggestions much appreciated.
     
  2. DwnNdrty

    DwnNdrty Registered Member

    Joined:
    Mar 28, 2007
    Posts:
    3,335
    Location:
    Florida - USA
    If you still have the original drive, create the Image again using the bootable Rescue Media cd and also restore it using the same. When creating the Image, be sure to put the check mark against Disk 1 so you image the entire hard drive.
     
  3. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,482
    Location:
    California
    The change may have been caused by TI making changes (especially if using TI 11). Your booting partition is probably the XP partition and TI may have set that as C: when you restored the Vista partition or Windows reassigned letters due to the changes.

    You should be able to boot to the Vista DVD, enter the Repair Mode, start the Command Prompt, run regedit, load the registry hive from the Vista partition, swap the C: and D: drive letters, unload the hive, close the Command Prompt windows, and reboot into Vista.

    You can see a sample of a similar procedure in this post. However, you don't want to remove the entries. Since C: and D: are both used, you will have to name C: to Y: (for example), D: to C: and finally Y: to D:.
     
  4. callmecheez

    callmecheez Registered Member

    Joined:
    Jun 12, 2008
    Posts:
    4
    Thanks for replies guys.

    I created the image from within XP-64, I didn't think to do it from the boot CD. I did, however put a check next to Disk 1, so both partitions were selected plus the MBR.


    This sounds along the right lines; its annoying that TI would make such crucial changes?

    I installed my OS's like this:

    750gig Hard drive:
    1. Installed XP first, chose 350gb partition c: Leaving 400gb free.
    2. Booted from Vista-64 CD, installed Vista into new partition d:

    As expected, Vista took over the MBR; and put its own OS menu in there. When I boot to Vista, then vista was C: and xp was D:; this is what has gotten mixed up in the restore. . .
     
  5. callmecheez

    callmecheez Registered Member

    Joined:
    Jun 12, 2008
    Posts:
    4
  6. DwnNdrty

    DwnNdrty Registered Member

    Joined:
    Mar 28, 2007
    Posts:
    3,335
    Location:
    Florida - USA
    Just last week I did a dual boot system with Vista and XP. I installed Vista first then XP. When Vista boots it is C and XP is E (optical drive is D). When XP boots Vista is C, XP is D and the optical is E.

    I also did several restores of the Backup I made, always with the boot cd, and it has always turned our correct regarding the drive letters. And just for "$h1t$ and grins", I even restored to a different computer altogether and the drive letters remained as in the original.

    So maybe you'll have better luck using the bootable cd on your dual boot system for all the True Image functions.
     
  7. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    TI didn't do this to you; Windows did. MudCrab's advice will fix it up.

    Because of the way Microsoft dual-boot setups work, restoring an image of one must be done with care because, by nature, the Windows boot process will follow its own predefined hierarchy when assigning drive letters. Here is how you could have avoided this:

    1. Before booting into Vista for the first time, use partitioning software (Acronis Disk Director, PartedMagic, etc) to hide the XP partition.
    2. Boot into Vista with the XP partition hidden. Now, Windows must assign the drive letter C to the Vista partition because it will be the only visible partition.
    3. Reboot into the partitioning software and un-hide the XP partition.
    4. Reboot into Vista and now the XP partition will be assigned the D drive letter.
    5. After this first boot the registry will contain these drive letter assignments and they will be persistent.

    It is that first boot that does the deed.
     
  8. truthseeker

    truthseeker Former Poster

    Joined:
    Jan 26, 2008
    Posts:
    977
    Actually this happened to me once, not sure why or what caused it. But in my case it was using the Desktop configuration from another installed windows on another partition.

    When I loaded C: windows, the C: Windows was using D: Windows' deskstop configuration.

    But now I only have 1 Windows and it hasn't happened since.
     
  9. callmecheez

    callmecheez Registered Member

    Joined:
    Jun 12, 2008
    Posts:
    4
Thread Status:
Not open for further replies.