problem with truecrypt drive

Discussion in 'encryption problems' started by derp, Aug 17, 2014.

Thread Status:
Not open for further replies.
  1. derp

    derp Registered Member

    Aug 17, 2014
    Hard drive is a 128gb SSD. OS installed on it is Windows 7.

    I started with a windows boot problem, where a particular driver would hang the operating system when it loaded. I could see the file in the safe mode list, boot and it would always freeze when it reached that file.

    So I put in the windows disk and boot into it thinking I can reinstall this driver.

    My hard drive was full-disk encrypted with truecrypt.

    I thought the windows cd would give me repair options, but once I selected the C drive, it starts installing right away. I was like O.O, realized I hadn't been prompted for my password, realized it was writing over the encrypted disk to load the windows files, and stopped it. But apparently the damage was done.

    I then rebooted and got to my truecrypt loader, which seemed to be working fine. I type in my password. Nothing. I type it in 10 more times. nothing. My password doesn't work.

    So I put in a new hard drive, install windows 7 on THAT hard drive, download truecrypt to THAT hard drive, and try to mount the original drive there. I try to recover the volume header from the internal backup and type in my password: not recognized as a truecrypt file. I was able to mount it without pre-boot authorization, which DOES require a password and my password DOES work, but when I mount it, it says "the file or directory is corrupted and unreadable". So I can't see or get any data.

    I also have a truecrypt rescue disk. When I boot to it, I can restore the volume key, but that doesn't actually fix anything. My password still doesn't work after I do that. I can restore the boot loader, but that doesn't make any difference either. I can't restore the system loader, because it says you need to decrypt first for that.

    So I try decryption. I set this to run. It is a 128 gb hard drive. It takes about 36 hours... except... it doesn't finish, because it hits bad disk errors and gets stuck on one (the sector number is very low, like 60 or something) and then spams that to the screen and won't do anything else. Also, if I interrupt the decryption early with Esc, the same thing happens. It keeps saying error on that sector 60something.

    I booted to Spinrite to try to fix the bad sectors, and it can see the disk, but hangs once I click to have it start checking. CHKDSK doesn't work at all because "Windows can't access the disk" and it can't work on reboot because on reboot the disk wouldn't be mounted.

    As this point I just want to salvage as much data as I can from the disk. The bad sectors seem to be what caused the boot problem with windows, although my trying to get into windows repair is what made it stop accepting my password. My recovery disk accepts my password, but the repair options there don't work, or with full disk decryption, it can't complete. Even though I tell it to ignore bad sectors, it gets hung up on one and even pausing the decryption triggers it too.

    I can take and post screen shots of anything if anyone needs to see it. I tried to be thorough. Since I have the recovery disk CD, I wonder if I can use my password to pull the key out of it, and then use 3rd party software to decrypt using the key? then I can run the windows repair or simply copy out my data and wipe the drive (and probably trash it if the bad sectors are such a problem).

    I hope someone has some ideas because I seem to have hit a wall.
Thread Status:
Not open for further replies.