problem with ShadowSurfer

Discussion in 'sandboxing & virtualization' started by awg1011, Jan 30, 2006.

Thread Status:
Not open for further replies.
  1. awg1011

    awg1011 Registered Member

    Joined:
    Jan 30, 2006
    Posts:
    4
    Well, I download the free ShadowSurfer and activated it with no problems, then lastnight I tried it, everything went fine....untill I went to go out of shadow mode. When I clicked restart now, my computer started shutting down normally, then it got to the blue screen that says "Windows is shutting down..." and stayed there. At first I just thought that it might take a little longer when coming out of shadow mode, but after 10 minutes of nothing happening, I pushed the reset button. After it restarted everything seemed to be working fine in normal mode.I contacted tech support, but haven't heard back yet.

    Any thoughts on this?

    Thanks.
     
  2. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,039
    Based on some others here, including myself, I wouldn't anticipate a speedy response if any from their tech support. My suggestion would be just try it again, and see if the problem persists.

    Pete
     
  3. eyes-open

    eyes-open Registered Member

    Joined:
    May 13, 2005
    Posts:
    721
    I think it just takes a while to flush the temporary data.

    I had the same experience myself. I don't think you can short cut this process. Although I agree the delay is excessive and I hadn't expected it.

    *I long ago set my pagefile to clear at shutdown which affects the shutdown speed anyway. Whether or not this conflicts with Surfer I don't know. I'll probably try it without the clear pagefile today and see.

    I can tell you that once I had waited (over 10 minutes) it did close down. I can also tell you that until I did this properly - It wasn't possible to disable Shadowsurfer properly.


    *I long ago set my pagefile to clear at shutdown - yeh well - it seemed liked the cool thing to do at the time......

    Background info - this is on a laptop (XP Home SP2) with 2.8GHz CPU x 1.18GB RAM.
     
  4. eyes-open

    eyes-open Registered Member

    Joined:
    May 13, 2005
    Posts:
    721
    Update to above:

    I have made the registry change and now page file is back to the default setting (ie not emptied at shutdown).

    Also permission to apply a hook hadn't been permanently registered with Process Guard. This has now been rectified and permission to apply hook has been given.

    Whether or not these had a direct effect I don't know for sure - but ShadowSurfer has now bedded in and is closing down in a timely fashion.

    A very visible indicator is that on close down - the desktop wallpaper changes to a Shadow Surfer design. This hadn't happened on the previous occasions when ShadowSurfer had delayed shutdown.

    So in short re my quote:-

    It's probably tosh and you just haven't managed to bed ShadowSurfer in yet. I would however give it a really good crack at the whip before forcing a shut-down. In my case and the reason I had waited for the shutdown rather than force it, was that the drive was clearly working (or trying to), not frozen throughout the shutdown period (I had a lot of MB's to shift ....).

    Sorry if I've caused any confusion - just happened to have downloaded ShadowSurfer myself yesterday and had exactly the same experience.
     
    Last edited: Jan 31, 2006
  5. eyes-open

    eyes-open Registered Member

    Joined:
    May 13, 2005
    Posts:
    721
    Back again - getting a little samey huh? Ok, well for what it's worth - by way of an experiment I reinstated the setting to clear the page file at shutdown.

    This recreated the massively delayed shutdown process again. So for me this appears to have been the key factor.


    Below is true for XP Home

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management > ClearPageFileAtShutdown. Default value should be 0. If the value is set to 1 then it is set to clear page file at shutdown.
     
  6. I use Shadowsurfer and it shuts down normally. I also have my page file disabled as I run with 1gb of ram and I don't need the paging.
     
  7. awg1011

    awg1011 Registered Member

    Joined:
    Jan 30, 2006
    Posts:
    4
    Pete, I kind have figured that out.:rolleyes:

    Thanks eyes-open, I don't rember if I set my pagefile to dump at shutdown, it's been a long time since I did any tweaks. I do have my pagefile a fixed size and on a dedicated partition, maybe I'll unprotect that partition and see what happens. I know I have it set to dump .dll files when the program using them is closed.

    I know that while it's shutting down and taking forever, the hdds are idle, quiet and no blinky lights, if there seemed to be any activety I wouldn't have reset.

    I'll try a few things and see what happens.

    Thanks!
     
  8. eyes-open

    eyes-open Registered Member

    Joined:
    May 13, 2005
    Posts:
    721
    Hi awg1011

    Sorry to have flooded your thread - My bad, I was posting as I was working through it. Yea my hdd was very, very active during my extended shutdowns - no freezing at all. It's why initially tho' common sense suggested it was too long a shutdown - I could see my machine was saying it had to go through it. When I did short cut the first time, after rebooting ShadowSurfer was still in active mode. Which ideally it shouldn't have been as I had set it to de-activate. So shortcutting seemed to have messed up that process and prevented ShadowSurfer from de-activating properly.

    I hope you manage to get it sorted. The only other stuff I have are the usual things I'm sure you're already doing. Going offline - closing down individually everything you can - then when it's all that's left trying to reboot. Similarly if you can get into safe-mode - trying a successful shut down from there. Well you know this stuff I'm sure......so as I've nothing left - accept this post as a gentle bump in the hope someone else jumps in.

    Hi ILikeLemonPie :)

    I haven't disabled my page file (I've yet to check that option out properly). I have reset my machine to its default state. That is not to clear the data in the page file at shutdown.
     
  9. awg1011

    awg1011 Registered Member

    Joined:
    Jan 30, 2006
    Posts:
    4
    No problem on the flooding. I found that if I select reboot later then reboot through the start menu, it reboots just like it would normally. As long as it keeps working that way, I'm not going to change anything on my system.

    Thanks.
     
  10. eyes-open

    eyes-open Registered Member

    Joined:
    May 13, 2005
    Posts:
    721
    Great :) - cheers awg1011.
     
Loading...
Thread Status:
Not open for further replies.