Problem with chkdsk

Discussion in 'backup, imaging & disk mgmt' started by aigle, Oct 30, 2007.

Thread Status:
Not open for further replies.
  1. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Recently started dual booting XP and Ubuntu. I have 4 pri partitions:

    1- XP NTFS
    2- Data FAT 32
    3- Ubuntu
    4- Data NTFS

    I tried to run chkdsk by command

    chkdsk C:
    It ran OK, no errors etc. Then I tried command:

    chkdsk C: /r
    Obviously it asked for an option to run chkdsk at start up and I agree. Next time when I rebooted, chkdsk tried to run but then stopped with the message.

    Can't open volume for direct access


    I am not sure why it can't access the volume? It never happened before dual booting. Is the problem related to dual booting?

    Anyway I don't care much bout this. I was running chkdsk without any special reason( was not having any problems at all) so I don't care if it can't run. Main problem is that now on every reboot, chkdsk tries to run but stops with same message. How can I get rid of it.

    Thanks
     
  2. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,779
    Just read this in a post, might be worth a try:

    "To cancel CHKDSK on start-up,open cmd type:CHKntfs /X C: "
     
  3. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Tried but doesn,t seem to work. Will do a reboot and see!
     
  4. nexstar

    nexstar Registered Member

    Joined:
    Jun 23, 2004
    Posts:
    371
    Location:
    Southampton, UK
    It has just taken me the best part of a week (off and on ;) ) to track down the same issue on one of my machines. I did a ground-up reinstall in the end only to find, late on in the re-build, that the problem reappeared again :eek: .

    Gradually getting rid of applications finally pinned it down to my DigiTV software that was running in debug mode and creating a log at startup before chkdsk had a chance to run. There were some registry entries that needed deleting in my case and the problem went away.

    You probably don't have a DigiTV card but I would guess that you may have some application that is conflicting in the same way. Had I found this a week ago it would have saved me a lot angst. However, I'm quite pleased with the newly built system now :) .

    Graham
     
  5. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    @Kerodo
    @nexstar


    Thanks for help. Command CHKntfs /X C: worked. No more issues.

    Now I wonder why after setting my system as dual boot I can,t run chkdsk on boot up. Any ideas?

    Thanks
     
  6. nexstar

    nexstar Registered Member

    Joined:
    Jun 23, 2004
    Posts:
    371
    Location:
    Southampton, UK

    Sorry aigle. I skipped the first part of your post when I saw the "Can't open volume for direct access" error o_O . Although I would imagine that a similar thing is happening in that something is getting in before chkdsk can get exclusive access.

    If you need to run it then it can always be done outside of Windows. In my case, I was just a bit surprised that anything else would have been able to get a look in before chkdsk.

    Graham
     
  7. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I will try to disable some security software. ActuallY I have run it in the past without issues with almost same setup. Only major change seems to be dual booting.
     
  8. Howard Kaikow

    Howard Kaikow Registered Member

    Joined:
    Apr 10, 2005
    Posts:
    2,802
    Dual boot has no effect on chkdsk.
    You have to choose the OS before chkdsk runs.
    At tat point, chkdsk has no idea there are any other OS, and chkdsk only checks the partition indicated.
     
  9. Rico

    Rico Registered Member

    Joined:
    Aug 19, 2004
    Posts:
    1,695
    Location:
    Texas
    Hi Guys,

    The best way to run 'chkdsk' is boot from your windows cd, choose 'R' to enter Repair Console, then run 'chkdsk.' This will avoid problems!

    Take Care
    Rico
     
  10. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Many people don,t have a window,s CD including me, just an image based recovery CD.
     
  11. appster

    appster Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    530
    Location:
    Paradise (Hawaii)
    Fwiw, as a Rollback Rx user I have found runninig chkdsk /r from WiinXP's Recovery Console will often corrupt my RB snapshots! Conversely, I've never encountered this when initiating chkdsk /f from within Windows!

    The following may remedy "chkdsk won't run at startup" problem, but because it involves a registry modification do backup first!
    1. Run the Registry Editor (regedt32.exe).
    2. Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:
    \SYSTEM\CurrentControlSet\Control\Session Manager
    3. Change the BootExecute entry from:

    autocheck autochk * /r\DosDevice\C: (or whatever)

    to:

    autocheck autochk *

    Reboot and see if that does the trick. ;)
     
    Last edited: Nov 2, 2007
  12. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Ok, will try it later. Thanks
     
  13. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I just restored a fresh iamge of my C partition and the problems seems to be solved. On first bootup after restore chkdsk ran OK. Will see what happens on next rebbot.
     
Loading...
Thread Status:
Not open for further replies.