Problem selecting Truecrypt file on a USB drive

Discussion in 'encryption problems' started by angel20142014, May 13, 2014.

Thread Status:
Not open for further replies.
  1. angel20142014

    angel20142014 Registered Member

    May 13, 2014

    I have a file container created on a USB 16GB USB drive. My encrypted truecrypt file is approximately 15GB of size, I do not remember exactly the total size as I created that a few month ago. This morning I mounted the file as I do every day, e.g. drive z: and I decided to WinRAR some folders. I opened WinRAR, selected a few folders from the z: drive (mounted truecrypt container on the USB drive) and added the folders to a new file. I specified the file to be saved on a different drive, (e.g. d:, one of my hard disks). So far so good, now here is what happened: the total size for all the folders I attemped to compress (.rar) was about 9GB. I left WinRAR running while I was taking a shower and when I came back I saw an error message saying that WinRAR could not access the Z: drive (mounted truecrypt container on the USB drive) anymore. I tried to select the truecrypt file on the USB drive to try to mount it again BUT this time I was not able to even see the file. Every time I tried to access the USB drive I got a dialog box saying: Please insert a disk into Removable Disk (F:). I can see that I make a terrible mistake trying to compress 9GB on a single file but I though the file was been created on a different drive (D:) and that wouldn't affect the USB drive. Now I am going crazy trying to figure out how to get back my files from the USB drive. Does anyone know what I can do about it? Thank you so much for all your help.

    Best regards,

  2. dantz

    dantz Registered Member

    Jan 19, 2007
    This is a flash drive, right? The "please insert a disk" message while the drive is already plugged in implies a hardware error. Possibly your flash drive or the USB interface has failed. Do other flash drives work normally when plugged into the same USB port? Have you tried plugging the problem drive into a different port? Have you tried it on a different computer?

    Recovering a lost TrueCrypt container file from a flash drive is not fun or easy, so let's hope it doesn't come to that.
Thread Status:
Not open for further replies.