PG3 no disk in A: drive after install of google desktop

Discussion in 'ProcessGuard' started by grey_ghost, Oct 25, 2004.

Thread Status:
Not open for further replies.
  1. grey_ghost

    grey_ghost Registered Member

    Joined:
    Apr 28, 2002
    Posts:
    60
    Hi,
    I get a random pop up alert from PG when opening applications or launching a browser.
    This occurred after installing Google Desktop.
    This alert appears twice. And the A: drive is accessed each time.

    please see enclosed “gif image“ below.

    Best regards,
     

    Attached Files:

  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Grey Ghost, Looks like you may have a pointer to your A drive enabled somewhere, I have seen this even without PG running, I guess you may have say a backed up document or maybe an installer which you may have permitted but did not complete or was left "hanging"
    Make sure that windows explorer is not trying to access the drive when you open it. This can happen with other removable storage if the drive is not cleared properly.
    Checking the paths in the alerts log may tell as may those shown in the properties in the security listed programs.

    HTH Pilli.
     
  3. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    Hi,

    it can be due to a bad file type association, as if (for instance) HTML or GIF files was linked to Process Guard instead of your browser, I remember to have seen such case in the past but do not remember with which software.

    gkweb.
     
  4. Ocol

    Ocol Guest

    Another thing to do is to go into Security in the Process Guard 3 menu. Check to make sure none of the applications listed referenve the A:\

    I ran a program from the A:\ and permitted it in Process Guard. After this I found that Process Guard was asking for the A:\. I think it was looking for this program.
     
  5. frogfoot

    frogfoot Registered Member

    Joined:
    Aug 8, 2004
    Posts:
    116
    Location:
    Yeovil UK
    I believe that when PG fires up it searches the location of all the programs in the 'Security' and 'Protection' tabs, searching for their icons. Hence if the program was on a floppy, and it has been removed then the error you encountered would result.

    This is a bit of a niggle, and hopefully will be resolved in the final version

    Regards
    Tom
     
  6. grey_ghost

    grey_ghost Registered Member

    Joined:
    Apr 28, 2002
    Posts:
    60
    Hi,
    Thanks for your help.
    I have tried a few things to correct this alert.

    Uninstalled Google Desktop. Did not correct the alert.

    With Google Desktop uninstalled I uninstalled PG 3 and did a registry clean.
    The alert was gone.

    When I reinstalled PG 3 the alert was back.

    It appears at Windows log on and with a manual start of PG.
    Also randomly with an application start.
    This does not affect the operation of PG.

    I also disabled all programs other than PG at start up and the alert appeared with PG
    I will look at the protection list as you recommended to see if there are any associations that may be looking at the A: drive.

    Best regards
     
  7. grey_ghost

    grey_ghost Registered Member

    Joined:
    Apr 28, 2002
    Posts:
    60
    Hi
    Your suggestions were correct.
    I had two references to applications run from A:.
    HijackThis and AboutBuster.
    Removed these from the list and the alert is gone.
    This shows how you can be led in the wrong direction when troubleshooting problems.
    I had forgotten about using the A: drive, and only remembered installing the Google Desktop in the same time frame. :)

    Thanks to all who responded.

    Best regards
     
    Last edited: Oct 25, 2004
  8. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Glad you got it sorted :)

    Pilli
     
Thread Status:
Not open for further replies.