PG and Windows Update v5

Discussion in 'ProcessGuard' started by WWW, Jul 28, 2004.

Thread Status:
Not open for further replies.
  1. WWW

    WWW Guest

    Does unchecking "Protection Enabled" also disable the four general block option? I have all 4 enabled.

    I installed the new Windows Update service (v5) a while ago. When I run the update just now, it prompted me to install again. That's what I did. The installation ended up with failure. I checked PG window log, it indicates a driver was blocked to install. I have lost the kernel driver name.

    I then unchecked "Protection Enabled", rebooted and tried again. The installation ended up with failure again. I thought it could be the "Block Driver and Service from Installing", so I unchecked all four general options. I also uninstall the v5 ActiveX object in my browser. I rebooted and tried again. This time it did not prompt me to install, everything seemed to be ok. The ActiveX object is not there anymore and the service is working fine.

    Is it a Windows update site glitch or I have to disable "Block Driver and Service from Installing" also?

    Microsoft seems to put the update service in the kernel. I remembered the name of the driver starts with letter "w". Anybody has a similar experience?

    Thank you
     
  2. Jason_DiamondCS

    Jason_DiamondCS Former DCS Moderator

    Joined:
    Nov 11, 2002
    Posts:
    1,046
    Location:
    Perth, Western Australia
    If you untick "Protection Enabled", then Process Guard is 100% fully disabled, so those 4 general protection options won't be in effect. You should always make sure it is disabled whilst doing any sort of Windows update.
     
  3. tre2004

    tre2004 Guest

    for some reason I can't go to V5. I installed it, then installed sp2 a day or so later, and I can't go to V5 at ALL even with SP2. It just takes me to V4. I even tried removing SP2 and installing again. I have tried removing the V4 folder, and V4 active x file.. And nothing.... If anyone has ANY idea as to what I need to do, PLEASE e-mail me..

    TRE2004@adelphia.net
     
  4. Marine06

    Marine06 Registered Member

    Joined:
    Jan 5, 2004
    Posts:
    17
    Just a thought, but could it possibly have something to do with your hosts file?

    I noticed with SP2, you must have automatic update and its respective services enabled in order to properly access the functions of windows update.
     
  5. Gavin - DiamondCS

    Gavin - DiamondCS Former DCS Moderator

    Joined:
    Feb 10, 2002
    Posts:
    2,080
    Location:
    Perth, Western Australia
    Yes, that might help. The required services are

    Automatic Updates
    Background Intelligent Transfer Service
    Event Log

    Disabling PG works fine and no problems with Windows Update
     
Thread Status:
Not open for further replies.