PCLeak.com quick test & Comodo Firewall Fail

Discussion in 'other firewalls' started by syncmaster913n, Mar 27, 2012.

Thread Status:
Not open for further replies.
  1. syncmaster913n

    syncmaster913n Registered Member

    Joined:
    Mar 24, 2012
    Posts:
    153
    Hi, I have Comodo Firewall enabled, proactive mode, ports are set for stealth for everyone. When I take the PCflank quick test (http://pcflank.com/test.htm) I seem to fail:

    Warning!
    The test found visible port(s) on your system: 135, 137, 138, 139

    Any ideas what might be wrong?
     
    Last edited: Mar 27, 2012
  2. King Grub

    King Grub Registered Member

    Joined:
    Sep 12, 2006
    Posts:
    814
    Are you behind a router? If you are, it will be router ports that are scanned and reported in the test.
     
  3. syncmaster913n

    syncmaster913n Registered Member

    Joined:
    Mar 24, 2012
    Posts:
    153
    Yes, I am behind a router! Thanks a lot for explaining.
     
  4. King Grub

    King Grub Registered Member

    Joined:
    Sep 12, 2006
    Posts:
    814
    Yeah, that would be the reason. If you want to test your software firewall, you will need to bypass the router.

    Also, there might be some settings in your router configurations where you can prevent those ports from showing up as open. Look for "Do not reply to ping on WAN" or something similar.
     
  5. Hungry Man

    Hungry Man Registered Member

    Joined:
    May 11, 2011
    Posts:
    9,148
    No, that website got my open ports for my computer, not my router. If it were checking my router it would have seen nothing but stealthed ports I assume.

    Instead it got 4 open ports associated with NetBIOS, which I'd forgotten to turn off.
     
  6. syncmaster913n

    syncmaster913n Registered Member

    Joined:
    Mar 24, 2012
    Posts:
    153
    Hungry Man, how did you turn off those ports?
     
  7. Hungry Man

    Hungry Man Registered Member

    Joined:
    May 11, 2011
    Posts:
    9,148
    Disabled NetBIOS in my ipv4 network properties. The other one I had to change with a registry key.
     
  8. Hungry Man

    Hungry Man Registered Member

    Joined:
    May 11, 2011
    Posts:
    9,148
    Alright... now I'm confused lol


    The test found visible port(s) on your system: 135, 137, 138, 139

    I'm on Ubuntu... so for whatever reason those ports are open on my router I guess?
     
  9. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    I think they are wrong, as those ports are not open on my comp to report, it as open. Try Grc Shields up (and any other similar) and that same port will report as closed
     
  10. Hungry Man

    Hungry Man Registered Member

    Joined:
    May 11, 2011
    Posts:
    9,148
    There's no way those ports should be open on Ubuntu... nothing else is showing them open.
     
  11. syncmaster913n

    syncmaster913n Registered Member

    Joined:
    Mar 24, 2012
    Posts:
    153
    Yeah seems to be an issue with PCLeaks, as all other services report these ports as closed.
     
  12. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    Actually, try their advanced port scanner and scan for those ports. They will report as closed. So something is wrong their end
     
  13. Hungry Man

    Hungry Man Registered Member

    Joined:
    May 11, 2011
    Posts:
    9,148
  14. syncmaster913n

    syncmaster913n Registered Member

    Joined:
    Mar 24, 2012
    Posts:
    153
    Yup, same here.

    Thanks guys.
     
  15. blacknight

    blacknight Registered Member

    Joined:
    Sep 25, 2007
    Posts:
    2,433
    Location:
    Europe

    Confirm. I use CIS with the Firewall enabled in Blocking Mode, I have a fw router - setted - ( also ports 135-9 closed with Windows Worms Doors Cleaner ), but PCflank quick test gives them visible. GRC and t1shopper.com passed.
     
    Last edited: Mar 28, 2012
Loading...
Thread Status:
Not open for further replies.