outpost security suite pro 7.5

Discussion in 'other firewalls' started by Dark Shadow, Aug 6, 2011.

Thread Status:
Not open for further replies.
  1. Dark Shadow

    Dark Shadow Registered Member

    Joined:
    Oct 11, 2007
    Posts:
    4,553
    Location:
    USA
    Has anyone tried or using this suite? I normaly do not like suites but this one is pretty nice.I took it out of learning mode staright away after a few pop ups its seems quiet.What do you guys think of it and any know problems or conflics. Feel free to post what ever comes to mind,including security settings,likes and dislikes.Thanks to all in advance.
     
  2. markcc

    markcc Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    185
    Location:
    Michigan, usa
    Hello djohn

    I'm running it right now on my Vista laptop along with Mamutu. It runs very light on my system. I have a lifetime license for the suite & I may keep this one for awhile. I really like the firewall & the control you have compared to other suites. The A/V part has improved over time. I'm a fan of having an HTTP scanner which this does not have. I'm going to use it for awhile & see what happens.
     
  3. gdiloren

    gdiloren Registered Member

    Joined:
    Jul 3, 2007
    Posts:
    146
    It's buggy. Hard to completely uninstall. In fact, I had the free suite, gave me problems with their fw, uninstalled, then had a one year license extension exchange with Avast Pro but couldn't install the suite cause it said I already had an old Outpost driver on my PC. I scanned regedit but can't find anything. So I stayed with Avast. Less trouble.
     
  4. wildernow

    wildernow Registered Member

    Joined:
    Feb 1, 2011
    Posts:
    28
    Seems to be quite light on resources. So far no problems. Will be trying it for 1 year to see. If it doesn't work out well I will go back to Avast Free.
     
  5. Dark Shadow

    Dark Shadow Registered Member

    Joined:
    Oct 11, 2007
    Posts:
    4,553
    Location:
    USA
    It seems to run good at the moment,not sure about the uninstall but the install took longer then anything I have tried, felt like it took forever that I almost cancelled it.thanks for the replies
     
  6. markcc

    markcc Registered Member

    Joined:
    Apr 8, 2008
    Posts:
    185
    Location:
    Michigan, usa

    You can use clean.exe that can be found in the install directory. You use it in safe mode. This should solve the problem.
     
  7. siberianwolf

    siberianwolf Registered Member

    Joined:
    Feb 15, 2009
    Posts:
    516
    afaik, the fw sw form agnitum-which is outpost fw- is among the best fw sw's. on the other hand, i really don't think security suites are the best solution. if it were me, i'd go w/ indepent sw's.
     
  8. Escalader

    Escalader Registered Member

    Joined:
    Dec 12, 2005
    Posts:
    3,710
    Location:
    Land of the Mooses

    The official user support forum for OP is

    http://www.outpostfirewall.com/forum/forum.php
     
  9. Dark Shadow

    Dark Shadow Registered Member

    Joined:
    Oct 11, 2007
    Posts:
    4,553
    Location:
    USA
  10. gdiloren

    gdiloren Registered Member

    Joined:
    Jul 3, 2007
    Posts:
    146
    clean.exe in safe mode and my PC boots in less than 30 seconds now. No Outpost suite for me. Keep it far from my pc!...
     
  11. tekkaman

    tekkaman Registered Member

    Joined:
    Sep 22, 2008
    Posts:
    164
    Well it has a complete firewall unlike many suites with firewalls that are no better than windows firewall. I like the USB protection it offers. What I don't like is that the scanning takes TOO LONG.
     
  12. The Seeker

    The Seeker Registered Member

    Joined:
    Oct 24, 2005
    Posts:
    1,100
    Location:
    Adelaide
    For those wanting to purchase OSS, use the coupon code 2YRSBETTER for 75% off ;)
     
  13. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    Thanks! :thumb:
     
Loading...
Thread Status:
Not open for further replies.