Openvpn 2.1 Vista 64 backslash shenanigans

Discussion in 'privacy technology' started by mikeo1313, May 30, 2009.

Thread Status:
Not open for further replies.
  1. mikeo1313

    mikeo1313 Registered Member

    Joined:
    Jun 22, 2006
    Posts:
    108
    1. My error msg:

    "Options warning: Bad backslash ('\') usage in server.ovpn:1: remember that backslashes are treated as shell-escapes and if you need to pass backslash characters as part of a Windows filename, you should use double backslashes such as "c:\\openvpn\\static.key"
    Use --help for more information."

    note: I've tried a number of combinations with how to reference the key files including replacing the \\ with \ or / , besides uncommenting the # where there is no use of referencing a folder, just to see. Config files I've seen that were posted to work for someone referenced files similarly as my config file. I even also tried commentiing out lines that reference log files with ;, jik, and still I get the same error stated in quotes above.


    2. here is my server config

    port 4030
    proto udp

    dev tap0
    dev-node tap-bridge

    #ca ca.crt
    #cert server.crt
    #key server.key
    #dh dh1024.pem
    ca "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\ca.crt"
    cert "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\server.crt"
    key "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\server.key"
    dh "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\dh1024.pem"

    ifconfig-pool-persist ipp.txt
    server-bridge 10.8.0.4 255.255.255.0 10.8.0.50 10.8.0.100
    server-bridge
    client-to-client

    ;duplicate-cn
    keepalive 10 120

    ;tls-auth "C:\\Program Files (x86)\\OpenVPN\\easy-rsa\\keys\\ta.key 0"

    cipher AES-128-CBC
    comp-lzo
    max-clients 100

    persist-key
    persist-tun

    status openvpn-status.log
    ;log openvpn.log
    verb 3
    mute 20

    ;crl-verify crl.pem





    3. My procedure & what I did.

    -When I installed the v2.1 rc16, I right clicked & ran as adimistrator, jik.

    in command prompt I ran

    -init-config...

    -edited vars.bat default parameters as mentioned in the how to + changed

    %programfiles% to %programfiles(x86)%

    **vista x64 doesn't install openvpn in its regular program files folder... instead its \program files (x86)\ ,,, the (x86) evironment variable does point to it.


    -excecuted vars, clean-all, build-ca, build-key-server server, build-key client1, build-dh & openvpn --genkey --secret ta.key
    { for keys I defaulted all values except common name & committed twice /w y where needed}

    -I renamed the tap-win32 adapter v9 to "tap-bridge"

    {My main ethernet which I bridged to tap-bridge gets its ip automatically from my d-link router's dhcp. That d-link dhcp is set to give 192.168.0.103 & is associated with its mac. I made sure the newly created bridge had both tap-bridge & local area connection checked in properties.

    once bridged. I couldn't ping 192.168.0.103 and ipcondig would show my ip address got assigned to something else in the d-link's dhcp range, within 1 minute vista recognized the change and would be able to access the internet again.}

    -I forwarded my udp port.


    o_O o_O o_O o_O o_O o_O o_O
     
Loading...
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.