OE Classic discussions and updates

Discussion in 'other software & services' started by FanJ, Apr 10, 2017.

  1. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    No problem of course!
    I just tried it, changing from English to German, from within the program itself. That doesn't seem to work on my system. Anyway, I want it to be in English. I was just curious.
     
  2. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
    It doesn't work here, either. I tried to change from English to German during the installation process - no luck. Then I tried to change languages within the program - that didn't work, either. I'll drop the developer a line later today.
     
  3. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
    Got an email from the developer today. Multi-lingual support is currently restricted to the "Account wizard". I've just tested it, it works. More comprehensive localization will follow within the next few days/weeks.
     
  4. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    Thanks Buddel!

    1. I don't know what "Account wizard" means here. What are exactly the required steps here from within the program itself (in case a person wants to change the language)?
    2. Why is there the option (from within the program itself) in Help > Select Language to change the language if that option doesn't work? Strange.
     
  5. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
    (1) Tools > Accounts > Add
    (2) Localization is still in the works. This option should work as soon as localization is fully implemented.
     
  6. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    OK, thanks.
    I realize that most updates for the Pro version are beta's, but IMHO it would be better when there would be a clearer explanation of new and/or fixed "features" (and not only on Twitter and Facebook (if they were posted there); some users don't go there)).
     
  7. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
    I agree. There is definitely room for improvement in this respect.
     
  8. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    there is an update today.
    Buddel, my dear friend, may I leave the rest to you, please (way too much eye vision problems again lately here)
     
  9. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    3,109
    Great news on OE Classic security!
    https://www.oeclassic.com/news_n78
    OE Classic v2.8 Pro Released (December 7, 2017)
    News
     
  10. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
    Yes, my dear friend, OE Classic Pro 2.8 was updated a couple of hours ago.

    New feature: Added multilingual support
    Bug fix: No longer jumps to the top of Address Book when items are deleted (Address Book and Main window)
     
  11. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    432
  12. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    Thanks Buddel and mood.

    =====

    having compared new and previous readme.txt the only difference is:
    bug fix [2017-12-07] No longer jumps to the top of Address Book when items are deleted (Address Book and Main window)

    =====

    it's time libeay32.dll and ssleay32.dll gets updated in OE Classic
    they are still at version 1.0.2l
    See:
    1 - https://www.wilderssecurity.com/threads/more-openssl-security-fixes.366904/page-2#post-2723701
    2 - http://www.securityweek.com/two-vulnerabilities-patched-openssl
    3 - https://www.openssl.org/news/secadv/20171207.txt :
    The vulnerabilities may be rated as low and moderate, but nevertheless.
     
  13. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    3,109
    I agree that it should be updated, but 1.0.2n was released on the same day as the new version of OE Classic.
    Perhaps the next version of OE Classic includes the new version of OpenSSL (1.0.2n)
     
  14. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    2,933
    Hi mood,

    Yes I do know that the updated version of OpenSSL 1.0.2 was released on the same day. I do understand that you cannot expect that that update will get included the same day into OE Classic.
    But there is more than this:
    About a month ago there was a previous update from OpenSSL:
    See:
    1. reply 42 in this thread.
    2. Post by Ron here
    3. http://www.securityweek.com/openssl-patches-flaws-found-google-fuzzer
    4. https://www.openssl.org/news/secadv/20171102.txt
    The OpenSSL organisation did advise there to upgrade to version 1.0.2m.
    That vulnerability may not have been the highest rate, but nevertheless.
    That is a month ago! That is enough time, I would think.
    If a developper uses OpenSSL, then you would expect him/her to keep him/herself informed about upgrades of OpenSSL and to include those upgrades as soon as possible.
    The developper can brag all day long about that Mailsploit at the OE Classic site, but keeping upgraded with OpenSSL seems to be too difficult ...
     
  15. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    3,109
    Maybe they forgot about OpenSSL :ninja:
    Or it is not a high priority because the Severity is "only" Low and Moderate.
    For example OpenSSL v1.0.2.g has one "High" Severity (https://www.openssl.org/news/secadv/20160301.txt) and OE Classic v2.4 was released (including 1.0.2.g) shortly after that.
     
Loading...