NTLDR is missing

Discussion in 'other software & services' started by rno2, Dec 9, 2007.

Thread Status:
Not open for further replies.
  1. rno2

    rno2 Registered Member

    Joined:
    Apr 21, 2005
    Posts:
    13
    I recieve this message NTLDR is missing......
    I have tried repairing it by copying it in the recovery console, adding it with bootcfg, setting and restting the partition to active and running fixmbr.
    Basically everything that has been suggested on the web that I could find.
    I can boot if I have the windows cd in.

    I am using windows xp pro with all updates.

    What else can I do?
     
  2. BlueZannetti

    BlueZannetti Administrator

    Joined:
    Oct 19, 2003
    Posts:
    6,590
    Were you doing anything in particular prior to this? Various solutions are given here

    Blue
     
  3. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    This happened to me recently also after some confusion when I added a new drive and was booting off the slave HD instead of the master. I solved it all by reordering the drives the way I wanted them, then reformatting and installing Win again.

    Some more info here also if you want to try copying files like ntldr and ntdetect.com off the Win disk to the root of the main drive, along with other stuff to try:

    http://support.microsoft.com/kb/318728
     
  4. rno2

    rno2 Registered Member

    Joined:
    Apr 21, 2005
    Posts:
    13
    This is a fresh install. It is also the same drive that I have always used for the os. I have changed nothing in the order of the drives. I did try the ms way to solve it, it did not work.
     
  5. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    For what it's worth, I believe that I did have success initially by copying those 2 files (ntldr and ntdetect.com) to the root of C: boot drive. I got it to boot ok, but it still complained about my boot.ini file being invalid. I was dual booting Linux and Xp on mis-ordered drives, so I went for the complete fix. But you might give those files a try and see if you can get it to boot... if that's what you tried and it failed, then I'm not sure how else to proceed, sorry.... for me, a reformat usually cures all... :)
     
  6. BlueZannetti

    BlueZannetti Administrator

    Joined:
    Oct 19, 2003
    Posts:
    6,590
    Is there any way that the partition numbering in the ARC path shown in the boot.ini file has changed? You know, the typical multi(0)disk(0)rdisk(0)partition(1)\WINDOWS path?

    Blue
     
  7. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    8,638
    Location:
    NSW, Australia
    Yes. I'd be looking directly at the boot.ini with a BartPE CD or EditBini.
     
  8. rno2

    rno2 Registered Member

    Joined:
    Apr 21, 2005
    Posts:
    13
    The boot.ini is fine when I check it.
     
  9. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    I think you're just missing Ntldr and Ntdetect.Com for some reason they either got corrupted or nuked. Did you try copying them from your Win disk? Boot off the Xp install disk into recovery console, then follow the instructions on the MS page to copy them from the I386 directory to your C:\ directory. That should fix it and let you boot. That's what the error message is complaining about.

    If you tried this, then just ignore me, but that's my best guess at the fix... ;)

    PS - You might also check your BIOS settings and make sure it's set to the right Drive/Partition etc...
     
  10. IS200

    IS200 Registered Member

    Joined:
    Jan 9, 2007
    Posts:
    32
    Location:
    pc repair dublin
    reinstall the os again
     
  11. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.

    You beat me to it. This is real common on a PC with the BIOS set to default, boot from floppy or CD first. (especially if a non-bootable floppy or CD are in one of the drives). Could even be a USB device if your BIOS supports it.
     
  12. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    Obviously something changed, and likely without your intervention. I would check anyway.

    1. Make sure there's nothing in the drives that it could be trying to boot to
    2. Check the BIOS to make sure every drive is being seen correctly and in the correct order (if the first drive is suddenly being seen as the last, then it may not boot properly - this happened to me recently)
    3. Set the desired drive as the only drive in the boot chain (disconnect other hard drives if necessary - once things are working correctly you can work on getting them back to how you want them)
    4. Boot to a partition manager to make sure that the correct partition is set as active and that there is nothing wrong with your partitions
    5. Boot to a drive tool (from the drive manufacturer) and run a diagnostic to make sure nothing is wrong with the drive (if you insist on using a 3rd party drive tool, do so after using the manufacturer's as SMART info algorithms, and likely more, vary between brands)
    6. Run FIXMBR
    7. Run FIXBOOT
    8. Run "bootcfg /rebuild" (http://www.computerhope.com/issues/ch000648.htm - this will take care of boot.ini) or do a repair install
    9. Delete all partitions, rebuild partitions, format (NOT "quick format"), and install Windows

    Do each step in order, without skipping any steps (even if one doesn't make sense, or you've already done it). Each will tell you more about the issue and help you narrow it down. If any of these things fail to work, then bring it up here and we'll have a much better idea of where to go. Don't forget to include information about your system hardware and how the drives are set up.
    I'm probably missing something, but that should do it. Obviously you will want to try booting to Windows before trying each next step.
     
    Last edited: Dec 9, 2007
  13. Espresso

    Espresso Registered Member

    Joined:
    Aug 1, 2006
    Posts:
    975
    Often that's due to a corrupt boot.ini file. Delete it and make a new one. You might want to make a few duplicate OS lines (multi(0)disk(0)rdisk(0)partition(1)\WINDOWS) and change the rdisk values (0,1,2,etc) just in case. rdisk will change depending on which drive is set as the boot drive.
     
  14. rno2

    rno2 Registered Member

    Joined:
    Apr 21, 2005
    Posts:
    13
    I have done all the suggestions and what was said in post 12. I still recieve the same error message.
     
  15. tgell

    tgell Registered Member

    Joined:
    Nov 12, 2004
    Posts:
    1,075
  16. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    You may well have a dead drive, but if you'd like to detail the steps you took and the results of each, as well as the information requested in my last paragraph, then I (or someone here) should be able to help you further. Unfortunately without that information, nobody can do more than guess.
     
    Last edited: Dec 10, 2007
  17. HURST

    HURST Registered Member

    Joined:
    Jul 20, 2007
    Posts:
    1,419
    This is a long shot, but maybe SuperGrubDisk can help. It has an option to repair the MBR. Very useful app, which helped me a lot on my first linux steps (and screw-ups)...

    I never had the missing ntldr problem when dual-booting in my main HD, but when trying if Linux could boot from an external USB HD, I got it all the time when booting from the USB. Could never fix it, so I'm back to having the 2 OS's on the same internal HD.
     
  18. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    Best bet to me is to set the drives up right, master and slave etc, then make sure the BIOS settings are pointing to the right drives/places, and then reformat and reinstall XP. If that doesn't cure it, then buy a new PC....
     
Loading...
Thread Status:
Not open for further replies.