"Not Connectable" with torrents & router

Discussion in 'LnS English Forum' started by Bmacguy, May 8, 2006.

Thread Status:
Not open for further replies.
  1. Bmacguy

    Bmacguy Registered Member

    Joined:
    Jul 12, 2003
    Posts:
    11
    I am brand new to LnS. XP SP2, DI-604 router.

    The router is configured for the port I use with torrents.
    I am using Outpost firewall on my older box, I *am* "connectable" on that box.

    Am trying LnS on my new box.
    I have imported the BitTorrent rule to the Enhanced ruleset and I specified the single port that I use with uTorrent.
    (I changed from the default port range 6881 - 6889.)
    The only other changes: DLL monitoring and stateful packet inspection are enabled.

    I have looked at Patrice's guide to using LnS with routers but I cannot even apply
    his first rule since I do not have any IGMP packets shown in the log.
    His rule requires an address provided in the IGMP log entry.
    There is one ICMP entry in my log, all others are UDF. (uTorrent is running)

    It is most important that I be "connectable".

    Any suggestions would be greatly appreciated.
     
  2. dja2k

    dja2k Registered Member

    Joined:
    Feb 15, 2005
    Posts:
    2,040
    Location:
    South Texas, USA
    Try to get phantom's ruleset v6, do a search here for it. It is better than the enhanced. With those rules, you just enter 3 rules for DNS and DHCP for your router and you are done.

    Okay to the other stuff, first I don't know if you meant that you imported one or two rules because there should be a client rule and a server rule. Make sure you imported the rules closer before +TCP block incoming. Furthermore, make sure you drop down the box and highlight TCP or UDP and both in the protocol. Utorrent needs UDP access for DHT server if you use it though. Also never use the default or near the defualt port like your choice from 6881 to 6889. Try something higher like 33468 for example. Alot of trackers hate the defualt port. Also make sure you uncheck TCP Stateful Inspection in the advanced settings if you are using them as that may decrease speed. I get 100 KB\s + with that. Highest I have seen is low 300 KB\s because I am behind a router firewall, yet I am still using port fowarding.

    About the ICMP, well I get alot of those blocked in my logs, but I don't bother with them. Most are unreachable blocked connections if I am correct.

    dja2k
     
  3. Bmacguy

    Bmacguy Registered Member

    Joined:
    Jul 12, 2003
    Posts:
    11
    Thanks for all the thoughtful info, dja2k.
    I finally found out that it was not a lns problem, it was port forwarding in my d-link router.
    I feel pretty dumb that I didn't bypass the router before asking the question.
    But all your info will be very useful and I am going to try phantom's ruleset.

    The strange thing is that port forwarding worked fine with the same router on my
    older win2k box. Now it doesn't work with winxp on new box.
     
Thread Status:
Not open for further replies.