Non-PAE Linux Distro

Discussion in 'all things UNIX' started by KeyPer4Life, Mar 9, 2015.

  1. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Looking for non-PAE Linux distro with LTS other than Mint. Dual boot setup and no issues with updates.
    Welcome any suggestions.
     
  2. Gullible Jones

    Gullible Jones Registered Member

    Joined:
    May 16, 2013
    Posts:
    1,459
    Just FYI - if the computer has an older Pentium M, you may be able to use 'forcepae' on the kernel command line. Some Pentium M processors support PAE but don't advertise it to the OS.

    Edit: Debian's 486 kernels are non-PAE. The standard 686 installer images (and live images) should ship with those kernels as well as 686-pae ones.
     
  3. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    There is a registry setting that will tell you whether Physical Address Extension (PAE) is enabled.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PhysicalAddressExtension

    If it is set to 1, then the kernel with PAE support was loaded at startup.

    Doesn't work so probably not supported. No hardware DEP support either.
    Limited to no more than 4G of ram on machine.
     
  4. Gullible Jones

    Gullible Jones Registered Member

    Joined:
    May 16, 2013
    Posts:
    1,459
  5. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Added the /pae switch to the end of Windows boot.ini file and rebooted. Windows now shows Physical Address Extension in System Properties . (HKLM registry key mentioned in post#3)

    Options are with DEP enabled:
    /noexecute= alwayson /pae
    /noexecute= optin /pae
    /noexecute= optout /pae

    Not sure if this will work though , but have seen some non-pae Linux distros to check out. Can boot and install from cd/dvd okay. I've had Linux distros installed before in VirtualBox and on the real system.

    The Linux terminal shows as one of it's flags (pae) for cpuinfo.
     
    Last edited: Mar 10, 2015
  6. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,096
    Hi KeyPer4Life,

    This article may help you achive what you are seeking: How To Install Ubuntu 12.04 On Non-PAE Capable Hardware.

    I also found this StackExchange link that elucidates the issues nicely: How can I install on a non-PAE CPU? (error “Kernel requires features not present on the CPU: PAE”)[/url.

    -- Tom
     
  7. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Used Ubuntu in the past and it was okay, but looking for something else. Ubuntu 12.o4 LTS is however supported till 4/2017 and 14.04 LTS till 4/2019. Do prefer a LTS distro with support till 2019. Still have several live cd's I can use while I'm checking into a more permanent solution.
     
  8. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    For testing I was able to boot up to a live Linux DVD distro with PAE kernel support.
    There was no error message and was able to go online with default browser.

    I'm hoping this means if I do a actual "install" that this will work on my system.
    Previously had a non-pae distro installed, but was unable to resolve update issues so it was removed.

    Also previouly had a dual-boot setup on separate drives (Windows & Linux) which worked except for
    when booting up. (boot menu) In order to resolve this issue I had to either install a
    third-party bootloader or go into the BIOS and select the drive Linux is installed on.

    Grub wasn't installed correctly to be able to give options to boot into Windows or Linux
    since there was no boot menu and Windows would automatically run.

    I also partitioned Linux on install or before usually with 4. (boot, swap, root & home)

    How do I get Linux bootloader to load at startup so I have the boot menu options to be able to select Linux
    or Windows? Putting Grub on Linux boot partition didn't seem to work so wouldn't it need to write to
    the Windows boot.ini file?

    Any help appreciated.
     
  9. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,096
    Hi KeyPer4Life,

    For Linux, I believe Grub has been superceeded by Grub2 for current Linux distributions.

    I'll have to look at my drives - i.e. I currently boot up a USB flash drive with Ubuntu 12.04.5 LTS.

    On my drives there is a format for a dual-boot setup that may work for you, however, as I have never used Grub2 afaik, it is in terms of Grub.

    Here is what I have on my Linux drive boot partition grub.conf file that worked for me, of course you will have to modify it to accomodate your selected two OSes (Windows version and Linux version details):

    default=0
    timeout=15
    splashimage=(hd1,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core (2.6.10-1.770_FC3smp)
    root (hd1,0)
    kernel /vmlinuz-2.6.10-1.770_FC3smp ro root=/dev/sdb2 rhgb quiet
    initrd /initrd-2.6.10-1.770_FC3smp.img
    title WindowsXP
    rootnoverify (hd0,0)
    chainloader +1

    And here is what I have on the corresponding WindowsXP bootable NTFS partition boot.ini file:

    [boot loader]
    timeout=1
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /noexecute=optout

    -- Tom
     
  10. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Thanks Tom. Noticed the change of Windows boot.ini file reads timout=1 instead of the default 30.
    Also you have both /noexecute=optin and /noexecute=optout listed.

    I added the /pae switch at the end of the boot.ini file. Only using one /noexecute though.
    Still in the process of testing different distros and hopefully can try installing soon.
     
Loading...