nod32mod_winnt_english_inet

Discussion in 'NOD32 version 2 Forum' started by serengeti, Dec 16, 2005.

Thread Status:
Not open for further replies.
  1. serengeti

    serengeti Registered Member

    Joined:
    Dec 16, 2005
    Posts:
    4
    I get the following error when I try to install the nod32 xp standard (trial ver)

    nod32mod_winnt_english_inet

    The installation cannot be completed. I have cleaned the registry of all references to nod32 and then tried reinstalling - it didn't work. Can anyone help?
     
  2. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Hi serengeti welcome to Wilders.

    Do the following files exist?

    C Drive> Windows> Temp

    C Drive> Documents and Settings> (User Name) XXXXXX> Local Settings> Temp

    Cheers :D
     
  3. serengeti

    serengeti Registered Member

    Joined:
    Dec 16, 2005
    Posts:
    4
    Thanks but I cleared both folders and it still didn't work!

    I did a sfc /scannow as well, in case I was missing some windows files.

    The actual message reads

    (121) nod32mod_winnt_english_inet
     
  4. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Further instructions HERE

    Let us know how you go...

    Cheers :D
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Please run "...program files\eset\install\setup.exe /test" and send the nsetup.log log to support[at]eset.com with a link to this thread. The error refers to a problem installing IMON or EMON, either because of a problem with Winsock or MAPI installed in your OS.
     
  6. wonderful_person

    wonderful_person Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    3
    I also have the same problem and have taken the steps advised in other threads for this problem to no avail.
     
  7. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Have you emailed support as advised after following the instructions?

    Cheers :D
     
  8. serengeti

    serengeti Registered Member

    Joined:
    Dec 16, 2005
    Posts:
    4
    I have sent the log to eset support as suggested.

    Here's the log for those who want a crack at solving this problem :).


    [2005-12-18 20:51:49.386] CmdLine: /test
    [2005-12-18 20:51:49.556] Resource: main.dll
    [2005-12-18 20:51:49.556] Is program installed?
    [2005-12-18 20:51:49.556] XML_ACCESS: C:\NOD32 - C:\NOD32\setup.xml
    [2005-12-18 20:51:49.887] Registry: old settings read
    [2005-12-18 20:51:49.977] global.xml created
    [2005-12-18 20:51:49.977] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\global.xml
    [2005-12-18 20:51:49.977] XML_ACCESS: C:\NOD32 - C:\NOD32\setup.xml
    [2005-12-18 20:51:49.977] Main settings added
    [2005-12-18 20:51:49.977] Engines nups
    [2005-12-18 20:51:49.977] InstallPath added
    [2005-12-18 20:51:49.977] LogPath added
    [2005-12-18 20:51:50.277] EngineFile extracted
    [2005-12-18 20:51:50.538] EngineFile extracted
    [2005-12-18 20:51:50.648] EngineFile extracted
    [2005-12-18 20:51:50.668] EngineFile extracted
    [2005-12-18 20:51:50.748] EngineFile extracted
    [2005-12-18 20:51:50.808] EngineFile extracted
    [2005-12-18 20:51:51.760] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpa\setupc.xml
    [2005-12-18 20:51:51.760] SetupAddComponentDescToGlobal
    [2005-12-18 20:51:51.760] Component added
    [2005-12-18 20:51:51.760] Componet libraries
    [2005-12-18 20:51:52.821] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpb\setupc.xml
    [2005-12-18 20:51:52.821] SetupAddComponentDescToGlobal
    [2005-12-18 20:51:52.821] Component added
    [2005-12-18 20:51:52.821] Componet libraries
    [2005-12-18 20:51:53.482] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpc\setupc.xml
    [2005-12-18 20:51:53.482] SetupAddComponentDescToGlobal
    [2005-12-18 20:51:53.482] Component added
    [2005-12-18 20:51:53.482] Componet libraries
    [2005-12-18 20:51:53.732] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\global.xml
    [2005-12-18 20:51:53.742] Admin settings added
    [2005-12-18 20:51:53.742] Cmd: 0 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2005-12-18 20:51:53.742] - krnstp.dll
    [2005-12-18 20:51:53.752] - ps_upd.dll
    [2005-12-18 20:51:53.762] Cmd: 0 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2005-12-18 20:51:53.762] - ps_amon.dll
    [2005-12-18 20:51:53.783] - ps_nod32.dll
    [2005-12-18 20:51:53.793] - ps_dmon.dll
    [2005-12-18 20:51:53.803] Cmd: 0 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2005-12-18 20:51:53.803] - imon.dll
    [2005-12-18 20:51:53.813] - ps_emon.dll
    [2005-12-18 20:51:53.813] ExeLibs: Init
    [2005-12-18 20:51:53.813] Cmd: 2 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2005-12-18 20:51:53.813] - krnstp.dll
    [2005-12-18 20:51:53.823] - ps_upd.dll
    [2005-12-18 20:51:53.833] Cmd: 2 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2005-12-18 20:51:53.833] - ps_amon.dll
    [2005-12-18 20:51:53.843] - ps_nod32.dll
    [2005-12-18 20:51:53.853] - ps_dmon.dll
    [2005-12-18 20:51:53.883] Cmd: 2 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2005-12-18 20:51:53.883] - imon.dll
    [2005-12-18 20:51:53.893] - ps_emon.dll
    [2005-12-18 20:51:53.913] ExeLibs: Load Current State
    [2005-12-18 20:51:53.913] Error: Couldn't open Administrator's XML : nod32.xml
    [2005-12-18 20:52:05.029] Registry: root written
    [2005-12-18 20:52:05.029] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\global.xml
    [2005-12-18 20:52:05.830] SetupCopyFiles
    [2005-12-18 20:52:05.830] Cmd: 3 Exelib: NOD32MOD_WINNT_ENGLISH_BASE
    [2005-12-18 20:52:05.830] - krnstp.dll
    [2005-12-18 20:52:07.022] - ps_upd.dll
    [2005-12-18 20:52:07.112] Cmd: 3 Exelib: NOD32MOD_WINNT_ENGLISH_STANDARD
    [2005-12-18 20:52:07.112] - ps_amon.dll
    [2005-12-18 20:52:07.122] AMONPLG Status: Install case begin
    [2005-12-18 20:52:08.033] AMONPLG Status: Install case end
    [2005-12-18 20:52:08.043] - ps_nod32.dll
    [2005-12-18 20:52:08.053] NOD32PLG Status: Install case begin
    [2005-12-18 20:52:08.343] NOD32PLG Status: Install case end
    [2005-12-18 20:52:08.343] - ps_dmon.dll
    [2005-12-18 20:52:08.404] Cmd: 3 Exelib: NOD32MOD_WINNT_ENGLISH_INET
    [2005-12-18 20:52:08.404] - imon.dll
    [2005-12-18 20:52:18.718] XML_ACCESS: C:\NOD32 - C:\DOCUME~1\owner\LOCALS~1\Temp\global.xml
    [2005-12-18 20:52:19.419] Deleting directory: C:\DOCUME~1\owner\LOCALS~1\Temp\NSetup\
    [2005-12-18 20:52:19.419] Deleting directory: C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpa\
    [2005-12-18 20:52:19.419] Deleting directory: C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpb\
    [2005-12-18 20:52:19.429] Deleting directory: C:\DOCUME~1\owner\LOCALS~1\Temp\nodtmpc\
    [2005-12-18 20:52:19.429] Exitcode: 121 NOD32MOD_WINNT_ENGLISH_INET
     
  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    There was a problem installing IMON, most likely due to problems with Winsock, and I'm affraid this cannot be resolved without reinstalling the whole OS. If you have network-related applications installed that might be potentially causing the issue, try uninstalling them.
     
  10. wonderful_person

    wonderful_person Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    3
    That's a pretty dramatic fix, are you sure thats the only way to resolve this issue? My log reads similar to serengeti's and I'd rather just not use Nod32 altogether if thats the only way I can get it to install.
     
  11. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    What about repairing Winsock, would this be worth a try? (just guessing here)

    Cheers :D
     
  12. oh YES!!!repair only the winsock i had the same problem and i had just repaired with winsockxpfix!!!thank you blackspear!!!!
     
  13. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    My pleasure, good to see it worked for you; hopefully it will do the same here.

    Cheers :D
     
  14. serengeti

    serengeti Registered Member

    Joined:
    Dec 16, 2005
    Posts:
    4
    I am happy to report that fixing winsock worked for me too!

    Many thanks to Blackspear and all the other guys who shared their problems and finding - I am so glad I didn't to reinstall my os :)
     
  15. wonderful_person

    wonderful_person Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    3
    Excellent, this fix worked for me too.

    Blackspear, you're my hero. :-*
     
  16. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
    Good to see, and glad you both had good results, thought it was worth a shot.

    Cheers :D
     
Thread Status:
Not open for further replies.