NOD32 v.4 (beta) and wireless connections

Discussion in 'ESET NOD32 Antivirus v4 Beta Forum' started by Zyrtec, Nov 18, 2008.

Thread Status:
Not open for further replies.
  1. Zyrtec

    Zyrtec Registered Member

    Joined:
    Mar 4, 2008
    Posts:
    534
    Location:
    USA
    I've been trying this beta ver. on a spare laptop I have and I've noticed that the problem caused by NOD32 trying to update the virus database BEFORE a wireless connection can be established has NOT yet been addressed.
    (At Windows boot)

    This problem plagued version 3.0 of NOD32.

    Is it going to be fixed on this version or not?


    P.S.: Marcos, please, this time respond to this inquiry.

    Thank you,

    Carlos
     
  2. pondlife152

    pondlife152 Registered Member

    Joined:
    Apr 23, 2008
    Posts:
    105
    Location:
    UK
    Yes, I'm testing V4 on my laptop too, and have noticed this. It does try again to update after an hour, but if you do not keep the laptop running this long, you have to manually force an update.

    Perhaps you can add an option to the logon event, a user set delay so that logon +1 minute, for example, could be used in the scheduler.
     
  3. philby

    philby Registered Member

    Joined:
    Jan 10, 2008
    Posts:
    940
    Have you tried unchecking "automatically detect settings" under internet options > connections > LAN ?

    This reduced my boot lag from about 3 minutes to 30 seconds worst case.

    This is probably not the issue you were referring to, but if it is then I hope this helps.

    Philby
     
  4. pondlife152

    pondlife152 Registered Member

    Joined:
    Apr 23, 2008
    Posts:
    105
    Location:
    UK
    No it isn't a lag as such, it just seems that NOD wants to connect before the wireless connection has been fully enabled. It's just a matter of a few seconds at most. A small delay before NOD checks for an update after logon would overcome this.

    Thanks for the info anyway.
     
  5. Brambb

    Brambb Registered Member

    Joined:
    Sep 25, 2006
    Posts:
    411
    Location:
    The Netherlands
    This might be a work around for your problem.

    - Start --> run --> gpedit.msc
    - Local computer policy --> computer configuration --> administrative templates --> System --> Logon (for vista, xp should be similiar)
    - Enable 'Always wait for the network at computer startup and logon'

     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    There's already a 1-minute delay, but it seems that it's not enough for some of you. We'll consider tuning it up a bit.
     
  7. pondlife152

    pondlife152 Registered Member

    Joined:
    Apr 23, 2008
    Posts:
    105
    Location:
    UK
    Okay, thanks for looking into it.
     
  8. war59312

    war59312 Registered Member

    Joined:
    Nov 30, 2002
    Posts:
    72
    Location:
    U.S.A
    Yeah why not 5 minutes, should cover older PCs too.

    Nice workaround.

    Only problem really I see with enabling this is that wireless is known for not being too stable so if your wireless connection happens to be out at boot-up windows will take forever to log-in, back to the win2k days.. Ouch!
     
  9. Clweb

    Clweb Registered Member

    Joined:
    Dec 28, 2002
    Posts:
    127
    Location:
    France
    Why not:
    if update failed because network error, the retry every 5 minutes until success. Then update at the configured frequency (1 hour default).
     
Thread Status:
Not open for further replies.