NOD32 firewall will not allow access to RADMIN

Discussion in 'ESET Smart Security' started by jimhancock, Jun 16, 2008.

Thread Status:
Not open for further replies.
  1. jimhancock

    jimhancock Registered Member

    Joined:
    Jun 16, 2008
    Posts:
    1
    I use Radmin 3.2 Remote Software to access my desktop computer while on the road. After I installed NOD32 v.3.0 the normal firewall settings block access to my computer. I have to either disable the firewall in order to be able to remotely connect to my desktop. Any ideas how to modify the firewall to allow this application to work?
     
  2. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    Interactive Mode prompts you to allow Radmin V3.2 both incoming and outgoing. You need to be able to get to your desktop locally to allow this incoming connection before you can connect remotely.
     
  3. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    I've just installed V3.0.667 after a complete uninstall and manual clean as per recommended procedures and now Radmin V3.2 Server is not prompted for access and does not work without disabling the firewall. So much for consistency. Manually adding the required rule rectifies the issue.

    Radmin Viewer was prompted for access as expected.

    Edit: Added screenshot of required rule for Radmin Server.

    Radmin Server Rule.jpg
     
    Last edited: Jun 22, 2008
  4. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    I did a little bit of experimenting with this one. Restarting the Radmin Server manually using the services management console and then connecting does generate a prompt for inbound access if no rule exists. I'm guessing the Radmin Server service starts before the ESS service or something like that so no prompt is generated.

    However, and this appears to be common ESS behaviour I really wasn't aware of, the rule created is pretty generic. Compare the manual rule I created above, which works fine and the automatically generated rule created below to see what I mean. Tick the box to remember and then always allow and you get a generic allow everything rule.

    Despite the warning prompt specifying the exact port and the exact protocol, the actual rule created is far more generic, allowing the given application complete access for UDP and TCP in both directions on every port.

    I guess you should really monitor each rule created by clicking advanced options on the warning prompt, then custom rule and then create. This creates a far more specific rule based on the actual traffic detected.

    Radmin Server Rule.jpg
     
  5. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    Turns out the computer hadn't been rebooted since the install. Services that are already running and connected to a listening port do not appear to generate an access prompt after ESS installation but will generate the prompt after a reboot or after restarting the service.

    I think this is normal and acceptable behaviour. Maybe ESS should suggest a reboot after installation.
     
Thread Status:
Not open for further replies.