NOD32 Does Not Start Up With Windows

Discussion in 'ESET NOD32 Antivirus' started by paul386, Jun 27, 2008.

Thread Status:
Not open for further replies.
  1. paul386

    paul386 Registered Member

    Joined:
    Jun 27, 2008
    Posts:
    1
    I downloaded the trial version of NOD32 and used it for the 30 days. I then purchased a 1 year license and registered and put my information into NOD32.

    At one point NOD32 stopped starting up with Windows. Even after I completed my registration it does startup automatically. :(

    Information:

    Windows Vista 64 bit
    NOD32 3.0 AV
     
  2. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Hi!

    Open EAV Control Center -> Setup -> Toogle Advanced mode -> Antivirus and antispyware protection -> Real-time file system protection -> Configure... -> Advanced setup -> Automatic real-time file system protection startup

    Check, if Eset service is set up to automatic start (run services.msc).
     
  3. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    Hi,
    I have exactly the same problems and followed your steps. It does not work!
    Any other advise?
    Thanks
     
  4. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Check, if ekrn.exe and egui.exe are between processes in Task Manager. Result write, please.
     
  5. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    Thanks,
    Yes they are there but only after I have started the program manually!
     
  6. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Restart OS and check it once again, please.
     
  7. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    After restart ekrn.exe shows up in task manager. egui.exe is misssing
     
  8. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    I thought. :)

    Open Notepad and copy to him this code:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "egui"="\"C:\\Program Files\\ESET\\ESET NOD32 Antivirus\\egui.exe\" /hide /waitservice"
    * If EAV is located in C:\Program Files\ESET\ESET NOD32 Antivirus


    File => Save as... => Type: All files, Name: repair.reg => OK => Run this file => OK => Restart OS and write result, please.
     
  9. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    Unfortunately I can not import the file. Receive an error message:

    "....is not a registry script. You can only import binary registry files from within the script editor"

    What do I next after this step has failed?

    Thanks
     
  10. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    PM me your email address, I send you that file.
     
  11. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    I would like to do so but the bulletin message board is unavailable...

    "The private messaging system is currently unavailable"

    o_O
     
  12. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    You have to enable it.:)

    User CP => Edit options => Enable Private Messaging
     
  13. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    Sorry, it IS enabled. Looks to me more like a system error:

    vBulletin Message

    The private messaging system is currently unavailable.

    Any solutiono_O

    Big thanks
     
  14. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Maybe :)

    File has been sent to your address.
     
  15. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    thanks, have received it already and it was added successfully to the registry...
    restarted computer, everything was loaded into systray, except egui.exe !
    But it shows up in msconfig !

    Here's listed what is running additionally as security software

    Comodo Firewall 3
    Comodo BOClean
    Super Anti Spyware 4.15
    Comodo Memory Firewall
    a-squared 3.5

    XP prof, SP2, 2GB RAM
     
  16. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Do you use A-Squared and others with resident modules?
     
  17. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    if you mean with "resident module" the permanent background presence than it is. Otherwise please explain.
    Thanks
     
  18. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Try to uninstall other AV softs besides firewall and write result, please.
     
  19. gatekeeperbkk

    gatekeeperbkk Registered Member

    Joined:
    Jun 29, 2008
    Posts:
    10
    Hello,
    no changes still won't load.
    I"ll let it be as it is. I can live with that and start the gui by hand.
    Anyway thanks for your help
     
  20. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Try to completely reinstall program.

    1) Uninstall NOD from Control Panel
    2) Reboot OS
    3) Remove these folders:

    Code:
    C:\Program files\ESET
    C:\Program data\ESET
    C:\Users\%username%\AppData\Local\ESET
    4) Remove these keys in Registry:

    Code:
    HKLM\Software\ESET
    HKCU\Software\ESET
    5) Download actual fresh copy of NOD from official ESET website and install it
     
  21. julmust

    julmust Registered Member

    Joined:
    Jul 23, 2008
    Posts:
    10
    Hello!

    I'm having the exact same problem here.

    ekrn.exe starts at startup but egui.exe doesn't, I have to start it manually.

    I'm using the ESET NOD32 Antivirus 3.0.667.0 Trial Version, downloaded recently from the ESET homepage.

    What might be causing this?
     
  22. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Hello,

    export this key from Registry and post it here, please.

    Code:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
     
  23. julmust

    julmust Registered Member

    Joined:
    Jul 23, 2008
    Posts:
    10
    I'm not sure how to do that, but I found the folder in "regedit".

    I think I found something, that might be the cause of this:

    egui REG_SZ "C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe" /hide /waitservice

    I have no idea what "/waitservice" is, but "/hide" sure seems like it could be the problem, no?

    If it is, how do I fix it?
    And what does /waitservice do?

    egui.exe is the only one there with the hide and waitservice lines.

    Thanks!
     
  24. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    /hide means it starts in the system tray instead of a full window, which is correct.

    /waitservice means that egui.exe waits until it sees ekrn.exe running before it executes.

    Your registry entry is correct, so more than likely there is something else running in memory which is keeping it from executing the startup entry.
     
  25. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    This problem occured immediately after installation or NOD works any time without problems?
     
Thread Status:
Not open for further replies.