I have a home built system with Windows 7 64 bit. I have Net Framework 1.1 and 4.5. Now I have a program that says it needs 2.0, 3.0 or 3.5. From what I have read on the 3.5 web page it will take care of from 2.0 to 3.5. I'm concerned because I did have 4.0 and there was an update to it that wouldn't install. It was recommended that I install 4.5. I just want to be sure that installing 3.5 doesn't foul up anything.