Need AUDACITY help please

Discussion in 'other software & services' started by MICRO, Nov 9, 2008.

Thread Status:
Not open for further replies.
  1. MICRO

    MICRO Registered Member

    Joined:
    Jun 8, 2004
    Posts:
    1,020
    Can anyone advise how to setup to record anything going through the sound card,
    Audacity help on the subject appears scant.

    I don't have a clue, the computer is new and SP2 - In Sounds and Audio
    under 'Sound Recording' it says either,

    Realtek HDA primary input or
    Realtek HD Digital input

    I have no idea which to use ?

    In trying to read about a bit here and there, is there something flaky re.
    codecs via this Realtek and trying to record via the sound card ?

    Or do I need to check other items in order to record via Audacity ?
     
  2. Firebytes

    Firebytes Registered Member

    Joined:
    May 29, 2007
    Posts:
    903
    For one thing your sound card must support capturing sounds via "Wave Out" or "Stereo Mix" to record any sounds going through your sound card. Mine initially didn't on my newer Dell laptop and I had to download a new soundcard driver from Dell to enable it to do so. You may have already seen these instructions from Audacity's website but just in case you have not:

    Can Audacity record RealAudio or other streaming audio?

    Windows and Linux

    With most Windows and Linux audio devices, it is possible to record whatever sound the computer is currently playing, including internet radio streams.
    In the drop-down menu on Audacity's mixer toolbar, choose “Wave Out” or “Stereo Mix” as the input source. (The exact name may be different, depending on your computer's sound drivers.) When you press the Record button, Audacity will capture whatever sound is playing on your computer's speakers. Note that on Windows Vista, the “stereo mix” option must be chosen in the Audio I/O tab of Preferences, in the “Recording Device” dropdown. On Windows, if you don't have a “Wave Out” or “Stereo Mix” option, or if it won't record, go to the system Control Panel and try to enable this option there. For instructions see: Using the Control Panel on the Wiki.
    If this doesn't work on your computer, you can instead use a cable to connect your computer's “Line Out” (speaker) port to its “Line In” port, and use Audacity to record from Line In.
    Mac OS X

    Mac OS X users can capture streaming audio using a program like Soundflower (free, open source), Audio Hijack or Wiretap Pro.
     
  3. Firebytes

    Firebytes Registered Member

    Joined:
    May 29, 2007
    Posts:
    903
    You need to have either "Wave Out" or "Stereo Mix" in the Audacity mixer menu.
     

    Attached Files:

  4. MICRO

    MICRO Registered Member

    Joined:
    Jun 8, 2004
    Posts:
    1,020
    Apologies FB., Time difference - Thanks for your help with this - I thought
    something must be in my way because that tiny Black arrow you show having clicked on in your pic. is 'dead' via greyed out -

    Ah, then read your highlighted
    Wiki addy re. same and that's why I can't use it - Been via the Cape in trying all the stuff mentioned re. this PITA Realtek but to no avail so will look
    to try the cable method to which you refer FB.

    How did I end up with this Realtek mess I wonder, would it be part of the Gigabyte Mobo ?
    I want to lock it in my mind to stay the hell away from it in future.
     
  5. Firebytes

    Firebytes Registered Member

    Joined:
    May 29, 2007
    Posts:
    903
    Micro,

    I hope you get your issues worked out with Realtek and Audacity. I did see one more thing on the wiki that might interest you. It is on the same webpage but above the part I linked to in my earlier post. This part deals directly with Realtek. You may have already read it but on the off chance you missed it:

    Mixer Input Toolbar Selector Disabled and Silence Recorded

    On Windows XP systems with RealTek audio hardware and up to date drivers, Audacity may not show the mixer drop down control or it may be disabled. Recording while playing a song records silence, regardless of what is chosen under the Audacity I/O preferences.
    This can be remedied as follows:
    - Go to the control panel and launch the "RealTek HD Sound Effect Manager". Access the Mixer Toolbox (via the wrench icon). Check the "Enabled recording multi-streaming" option (that is the key). This will create a new sound device (and also lock up anything playing music at that time, so close them first). You want to see a volume for "Stereo Mix" that should not be disabled. If it is disabled (red cross over its volume icon), enabled it. Nothing will change in Audacity, but you will now be able to record what is being played!
    - In general remember that you can also go To Start, Accessories, Entertainment, Volume Control. Use the Options to access all the settings or flip between recording and playing. Make sure nothing you need is muted or has its volume set to zero. Do note that if you have a microphone plugged in, you may want to mute it to record something playing from the internet for example, just dont forget about the fact that you muted it here. These settings can usually also be accessed via the "RealTek HD Audio Manager" which can be set to appear in the system tray.
    In Audacity, for Audio I/O Preferences you can simply use the defaulted "Microsoft Sound Mapper" select for playback and recording device. You may consider changing the "Recording Channels" to "2 (Stereo)".
    Card Not Supported

    Some high-end multi-channel cards on Windows systems don't use the standard Windows mixer interface and volume control, but instead supply a custom mixer application which Audacity can't hook in to. In these cases you need to select the recording settings and levels using the custom mixer application shipped with the sound card. Recording should work as normal with the card however.

     
  6. MICRO

    MICRO Registered Member

    Joined:
    Jun 8, 2004
    Posts:
    1,020
    Thanks very much FB for the time coming back at me with the above info. -
    No, I am pretty hopeless when reading reams of tech. stuff unless it's specific like yours in these posts and so I missed this important info. above -

    I just a minute ago started checking and yes I had done a couple of the things while snooping around in Realtek's CP but I noticed the 'Red cross' to which you refer
    was disabling the "Stereo Mix" and so I've Enabled that but have now run out of time but will get time later today to check out the rest and tomorrow
    will let you know FB how I went.
     
  7. MICRO

    MICRO Registered Member

    Joined:
    Jun 8, 2004
    Posts:
    1,020
    Well it worked like a charm FB, after following the above to the letter, including the Prefs. change to Stereo2 - I tried playing an MP3 in Aimp2 and recording it via Audacity and the result was shaking my speakers and my shack, dreadful noise - But then I could see the volume slider on the Audacity mixer toolbar was high so I dropped it down to 2.5 - 3.0 for the
    re-recording before exporting as an MP3, good as gold - tried using
    the Gom player/Audacity same good result.
    I will try one of my favourite Apps. tomorrow, MP3 Direct Cut,/Audacity.

    Many thanks are due to you,
    Kind Regards.
     
Loading...
Thread Status:
Not open for further replies.