My location appears to block VPNs, how to bypass it?

Discussion in 'privacy technology' started by mattdocs12345, Feb 17, 2014.

Thread Status:
Not open for further replies.
  1. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
    My undisclosed location appears to be blocking VPN access. I would like to bypass this blockade.
    Here is what Im using:
    OS
    openSUSE 13.1 KDE
    VPN
    SecurityKiss

    I received the following form Security Kiss:
    • Client ID
    • Password
    • Pre-Shared Key (PSK or secret)

    I followed online instructions:
    - created new PPTP VPN
    - added Gateway from their list
    However the VPN doesn't even appear to be connecting. No error message, nothing.
     
  2. lordraiden

    lordraiden Registered Member

    Joined:
    Jan 30, 2006
    Posts:
    3,066
  3. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
  4. MrBrian

    MrBrian Registered Member

    Joined:
    Feb 24, 2008
    Posts:
    6,032
    Location:
    USA
  5. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
    It's for debian not for openSUSE, there is no .rpm package.
     
  6. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,024
    If your VPN service supports it, try switching to UDP on nonstandard ports. If that doesn't work, try connecting in TCP mode. TCP on port 443 (aka HTTPS) should get through anything sane.

    Edit: I see that you're using PPTP. That's a bad idea. Use the OpenVPN configuration for SecurityKISS.
     
  7. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
    I don't think the location from which I browse the net has enough manpower to decrypt PPTP so Im okay with using it. And I don't mind if uncle sam knows that im watching netflix...

    Now how to connect in TCP mode? i don't see an option anywhere.
     
  8. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,024
    That's not an option for PPTP.

    I've read that OpenVPN is tops for getting through firewalls. But the comparison might not have included PPTP. I recommend that you just try it.
     
  9. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
    Tried OpenVPN for Security Kiss and it worked. I chose port 443 and connected without a problem. Funny because another paid VPN service wouldn't let me connect via 443.
    Anyways Im glad I got it working and on a free VPN service too :)
     
    Last edited: Feb 17, 2014
  10. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,024
    Is SecurityKISS on UDP or TCP? What about the other VPN?

    Cool :)
     
  11. mattdocs12345

    mattdocs12345 Registered Member

    Joined:
    Mar 23, 2013
    Posts:
    1,785
    Location:
    US
    Not sure....
    Here is what Security Kiss VPN states in its very brief Readme for OpenVPN

    What I did was just this:

    Gateway port 443
    Use LZO compression
    Use TCP connection

    So according to the readme SecurityKiss is on 443 port and therefore connected through TCP. I tried using Gateway port 123 but it wouldn't connect.

    The previous VPN service that I used (PIA), I remember changing port to 443 but my computer still wouldn't connect. Although I admit I might have had the configuration messed up since this was my first time setting up OpenVPN on linux.
     
  12. mirimir

    mirimir Registered Member

    Joined:
    Oct 1, 2011
    Posts:
    6,024
    OK, so SecurityKISS works in TCP mode on port 443.

    I just asked on PIA support chat. They say to use ports 80, 110 or 443 for TCP, and 53, 1194, 8080 or 9201 for UDP. I suspect that you changed to port 443, but were still trying to connect in UDP mode.

    Port usage varies among providers. AirVPN, for example, uses port 443 for both UDP and TCP modes.
     
Loading...
Thread Status:
Not open for further replies.