MSN scan command not working?

Discussion in 'ESET NOD32 Antivirus' started by _Logan, Feb 25, 2010.

Thread Status:
Not open for further replies.
  1. _Logan

    _Logan Registered Member

    Joined:
    Dec 19, 2007
    Posts:
    18
    I'm using NOD32 antivirus (latest version), on Windows 7 64-bit.

    Under the scan file transfer setting, I have:
    'C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe' --log-file=log.txt --action=clean

    However, anytime I receive a file over windows live messenger I get this error: The virus scan could not be completed. Please check your settings in Tools > Options > File Transfer.
     
  2. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Ensure that your cleaning paramaters are correctly entered. Generally speaking, it may be an issue with the size of the file(s) that you are swapping.
     
  3. _Logan

    _Logan Registered Member

    Joined:
    Dec 19, 2007
    Posts:
    18
    Checked... all good there. Still an issue?

    Seems to happen for any size file. >6mb... even <1mb.
     
  4. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Try unchecking the file scan paramater and see if there is any difference.
    NOD32 will protect you all the same.
     

    Attached Files:

  5. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    619
    Location:
    Sydney Australia
    I agree with siljaline, just uncheck the MSN scanning options as shown. Nod32 scans the file transfer in real time. Even if you get the scan command to work, all you are effectively doing is getting Nod32 to scan the file twice. No gain, just an unneeded performance hit.
     
  6. netjunky

    netjunky Registered Member

    Joined:
    Feb 28, 2010
    Posts:
    3
    I had similar problem, but article from knowledgebase solved the issue. Still I got question on similar topic.
    Is it possible to somehow disable the ecls console popup when receiving file? Maybe there are some unknown to me parameters. Because when I used Vista(now using Win7) I had NOD32 v.3(now v.4) and it was perfect. No popups just quick scaning.

    I really hope there is a way.
     
  7. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    What exactly is your problem ? Your IM Client is ? Please provide some details as to what you would like us to assist you with.

     
  8. netjunky

    netjunky Registered Member

    Joined:
    Feb 28, 2010
    Posts:
    3
    No, everything works fine.
    Problem is, that when I reseive some file trough my IM Client, where antivirus is set so:
    '"C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" --log-file=log.txt --action=clean' popups console window like in picture shown here

    a89d1b223ea3.png

    It is very disturbing. Is it possible to somehow suppress this poping out console window? Maybe there are some parametres for that?
     
    Last edited by a moderator: Mar 6, 2010
  9. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Uncheck the scan parameter. This should suppress the pop-up, as was previously noted in previous replies to your query.
     
  10. netjunky

    netjunky Registered Member

    Joined:
    Feb 28, 2010
    Posts:
    3
    Well, I unchecked it and it gave me those opportunities:
    1. I can receive *.txt files
    2. I can send *.txt files.
    But when it comes to:
    3. Sending *.rar file, then IM Client popus up a window where I have to chose what antivirus to use. So the problem remains as it was before. Uncheking the file scan parameter doesn't help.
     
  11. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    I've posted some time ago that there is a punctuation mark error in ESET KB but they just refused to amend their article causing more confusion to their users :mad:

    It should be :

    "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" --log-file=log.txt --action=clean
     
  12. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    The ESET solultion lists the scan parameter as follows:
    Code:
     'C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe' --log-file=log.txt --action=clean 
    The punctuation appears to be the same as you posted nanana1.

    I have sent feedback that their may be an issue with the parameter, thanks for advising of this.
     
  13. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    Nope.

    KB article punctuation mark is '
    The correct punctuation mark should be "

    Actually, if you see the KB more carefully, you will note that ESET gave the command line as ' but their image shows " :p

    What a simple mess of symbols here ;)
     
  14. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    Another working scan command line that I use is :

    "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" /clean-mode=strict /quarantine

    Again, notice I apply the correct " punctuation marks :p
     
  15. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Code:
    'C:\Program Files\ESET\ESET Smart Security\ecls.exe' --logfile=log.txt --action=clean 
    Code:
    'C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe' --log-file=log.txt --action=clean 
    Would ESET ammend the solution to reflect the discovery that quotations required for the parameter are incorrectly cited.
     
  16. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    Not changed yet.:thumbd:
     
  17. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Revising KB articles does take some time, though, the graphic does show double quotations when entering the parameter to Windows Live Messenger.
    I have sent feedback to askESET@eset.com with this information. Hope to see it changed soon. :ouch:
     
  18. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    Thank you !..You are a good man to help many avoid this silly problem.:thumb:

    Yes...the graphic showed the double quotations except that most people including myself would choose the quicker (lazier) method of copying and paste the text which has the problematic single quotation mark and run into msn scan not working problem. May be just a wrong symbol but it sure took me some time to figure this out back then :oops:
     
  19. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    The default settings (at the risk of sounding like a broken record), are:
    With double quotations at the beginning and end of the parameter.

    Code:
     ''C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe' --log-file=log.txt --action=clean" 
     
  20. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947

    The correct command line (tested) should be :

    "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" --log-file=log.txt --action=clean
     
  21. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    I think we have ESET's attention at this point, nanana1 :)

     
  22. Hollowstriker

    Hollowstriker Registered Member

    Joined:
    Mar 28, 2010
    Posts:
    50
    I am having exactly the same problem as described by netjunky:

    Windows Live Messenger 8.1.0178.00 on a Windows XP SP3 machine with ESET NOD32 Antivirus v4.2.35.0

    The scan parameter is as per the now updated ESET KB: SOLN549 article:

    Code:
    "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" --log-file=log.txt --action=clean
    
    There is no problem sending nor receiving files, but the issue is that when the file transfer is finishing, a distracting command line window pops-up (see screenshot). Worse still, a text file, log.txt is created on my desktop instead of C:\Program Files\ESET\ESET NOD32 Antivirus\log.txt as in the KB article.

    Is there anything that can be done about:
    1) Removing that nasty command line window *without* unchecking the scanning option?
    2) Not creating that log.txt on my *desktop*

     
  23. nanana1

    nanana1 Frequent Poster

    Joined:
    Jun 22, 2007
    Posts:
    947
    @Hollowstriker,

    You may use my scan parameter below.

    "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe" /clean-mode=strict /quarantine

    Hope this helps.
     
  24. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    What about putting "start /min" before ecls, ie.
    start /min "C:\Program Files\ESET\ESET NOD32 Antivirus\ecls.exe"
    followed by the desired parameters?
     
Thread Status:
Not open for further replies.