Move internal SATA hard disk to external USB case —> Truecrypt does not work any more

Discussion in 'privacy technology' started by mattad, Mar 23, 2015.

  1. mattad

    mattad Registered Member

    Joined:
    Mar 1, 2006
    Posts:
    66
    At first I connected a (second) 3TB hard disk by SATA cable directly to the motherboard.
    Then I formatted this hard disk directly by TC 7.1a and assigned a new password.
    I did not create a partition on this second hard disk but formatted the whole hard disk (as I did successfully before a couple of times with other hard disks).

    Everything worked fine. I can mount and copy files to TC volume.

    Then I dismounted the TC, shutdown computer and mounted the hard disk into an external USB 3.0 hard disk case. I connected this external case with an USB cable and started up my Win 7 system.

    Now I tried to (auto-) mount this external hard disk through TC GUI.

    Much to my surprise the hard disk volume cannot by mounted by TC although it is physically found.
    It seems to me that a TC volume needs not only a password for access.
    Moreover TC remembers as well if it is an internal SATA or external USB hard disk.

    If I switch back to internal connection everything works fine again.

    Can someone confirm this?
     
  2. Paranoid Eye

    Paranoid Eye Registered Member

    Joined:
    Dec 15, 2013
    Posts:
    174
    Location:
    io
    Yup perfectly normal noticed this many years ago, I am unsure what the exact reasons are but I think it has to do with the enclosures usb to sata controller chipset.

    It sees the hdd different more of an external device I have just learned to live with it frankly but since the hdd is always more faster directly connected to the PC sata port you could just keep the hdd loose and outside of the enclosure its faster after all.
     
Loading...