Minor, but annoying NOD32 bug under Vista

Discussion in 'ESET NOD32 Antivirus' started by paroots, Jun 29, 2008.

Thread Status:
Not open for further replies.
  1. paroots

    paroots Registered Member

    Joined:
    Jun 11, 2005
    Posts:
    72
    I have installed NOD32 V3 several times on PCs running both Windows XP Pro and Windows Vista Home Premium. In each case, I have noted a bug in Vista that does not occur in XP. When you go into Tools / Log Files / On-Demand Computer Scan and attempt to delete a previous scan log (by right clicking and selecting Delete) it refuses to do so under Vista.

    It should also be noted that NOD32 has another long standing bug. When a scan is not allowed to complete (eg, rebooted prior to completion) the log shows 'Scanning in progress' forever. It is these scans that I wish to delete since the status is not accurate. This bug occurs in both XP and Vista.
     
  2. Leschy

    Leschy Registered Member

    Joined:
    Sep 23, 2007
    Posts:
    55
    Location:
    Munich
    can confirm both bugs. i think it has something to do with uac of vista.
     
  3. paroots

    paroots Registered Member

    Joined:
    Jun 11, 2005
    Posts:
    72
    Thanks Leschy. Hopefully, they can fix in the next version. As mentioned, it's an annoyance more than anything else.
     
  4. ASpace

    ASpace Guest

    Hi!

    Mine deletes successfully with UAC enabled and admin account. Haven't tried with limited account .

    I can confirm this , too.

    I can also confirm another bug in 3.0.667 (in Vista only) perhaps related to the rights of egui.exe . Hopefully ESET will fix it in the next build
     
  5. paroots

    paroots Registered Member

    Joined:
    Jun 11, 2005
    Posts:
    72
    Thanks HiTech_boy. I am also running as administrator and have UAC enabled. Wonder why the difference?
     
  6. John2222

    John2222 Registered Member

    Joined:
    Sep 27, 2005
    Posts:
    140
    I noticed a similar (maybe related) bug with Vista:

    I had created a new profile in the "on demand computer scan" section. Later I tried to delete the newly created profile, but it's still there even after rebooting.

    Not a show stopper but I should be able to delete it.
     
  7. ASpace

    ASpace Guest


    Unfortunately , I can confirm this one , too . The profile doesn't go away even after service restart , even after I apply the default settings , even after I apply my previous cfg , even after I run the GUI as admin to modify the settings :ouch:
     
  8. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    I can confirm this is an issue with XP Pro also by monitoring with ProcMon and RegDefend. The related profile key is deleted but subsequent cycles shows the profile key being re-created. The only way I have found at this time is to go into the registry and manually delete the appropriate keys related to that profile. Perhaps it can be sucessfully removed in safe mode :doubt:

    As a side note, creating a profile in Setup\Antivirus and antispyware\Update does not exhibit this same occurence as the profile is actually deleted and stays deleted.
     
  9. RAD

    RAD Registered Member

    Joined:
    Apr 2, 2007
    Posts:
    332
    Check to see if the file, or folder in which it resides, is set to "Read Only".
     
  10. paroots

    paroots Registered Member

    Joined:
    Jun 11, 2005
    Posts:
    72
    Thanks RAD. Yes, it was set to 'Read Only'. I changed it, but I was still unable to delete logs within the NOD32 window. I found the log files at:
    C:\Program Data\ESET\ESET NOD32 Antivirus\Logs\eScan

    I was able to delete the files from Windows Explorer and of course, they were then removed from the NOD32 log display
     
Thread Status:
Not open for further replies.