Microsoft Visual C++ Runtime Error! SAV client fails to start

Discussion in 'other anti-malware software' started by Esraa Almahi, May 5, 2014.

Thread Status:
Not open for further replies.
  1. Esraa Almahi

    Esraa Almahi Registered Member

    Joined:
    May 5, 2014
    Posts:
    2
    when i want to do any change in ESET Endpoint antivirus, i receive the error message "Eset GUI has stopped working: runtime error", i uninstalled the antivirus and installed it again but the problem is still there
     
  2. Esraa Almahi

    Esraa Almahi Registered Member

    Joined:
    May 5, 2014
    Posts:
    2
    i faced this error and i searched for a solution here but i couldn't find it, now i found the solution posted by Davidatwork in other website, and it worked for me beautifully i will share it with you...
    For the sake of those you may have this problem in the future, here are the steps that corrected my issue:

    • Go to a command prompt and run wbemtest
    • Click the Connect button
    • Replace root\default with root\securitycenter and click Connect
    • You will be returned to the original screen, now click the Enum Classes button, leave the Superclass info box that appears as is (empty) and click OK
    • On the Query Results screen, highlight AntivirusProduct and choose the Delete button.
    • Close the Query windows and exit wbemtest
    • Now either reinstall or repair Symantec Antivirus Corporate Edition

    Interesting note, in my case when I re-entered the wbemtest after fixing my problem, the AntivirusProduct class no longer existed, even after a reboot. I can only guess this was a remnant of an older ESET AV product or some other software package placed it there and it was causing a conflict with ESET AV.
     
Loading...
Thread Status:
Not open for further replies.