Maxtor hard drive can't be detected by windows

Discussion in 'other software & services' started by VIPER99, Oct 30, 2005.

Thread Status:
Not open for further replies.
  1. VIPER99

    VIPER99 Registered Member

    Joined:
    Jul 4, 2005
    Posts:
    78
    Hey all,

    I've been working at this problem for a week now and I'm at the point were I'm going to tear out all my hair.

    Anyway I might aswell start at the begining....

    Last week my sister used my computer while I was at work. When I came home it looks the system had "crashed" which caused it to load to the select startup method window (normal, safemode etc) Anyway I tried restarting the system to no advail. The first time I tried starting up I was given a bunch of letters right before the windows logon screen which didnt come up. This gave me the impression that the mbr had become damaged.

    Next I tried using the windows recovery system on the cd but the recovery system and the install wizard could not detect the hard drive (this prevents me from doing a "fixmbr"). After trying this, strangely I was able to get to the windows logon logo. But, the system would just hang at the logo for awhile then restart all over again.

    Next I tried installing Windows on my secondary hard drive to see if a running install of XP Pro would detect the drive. After the install I tried going into the mmc to see if the disk management snappin could see the hard drive and of course it didnt.

    Next from the advice of a friend I located a live Knoppix CD to see if I could get access to the drive that windows couldnt see. Strangely enough the Knoppix CD could see the drive and all the information on it. From here I was able to copy all the data off the apparently faulty drive to a partition on my second hard drive.

    Next I tried formating the faulty drive by using fdisk. After doing this I still couldnt see the drive or even access it. So, I fiddled around with a ton of things then I deceided to try and install mandralinux on the faulty drive.

    Believe it or not the linux install didnt just detect the drive but it installed on it AND i was able to boot to the linux OS after the install. So after seeing this I tried booting into my second hard drive again to see if XP could see the other hard drive. Of coarse it didnt.

    Finally I decided to go to the manufactures site of the hard drive (Maxtor) to see if I could find anything there. I came across a program called PowerMax which you place on a floppy disk and boot to it. This program is supposed to be able to detect the Maxtor hard drive and check it for errors. So, I downloaded it and gave it a shot but off course it couldnt see the drive either.

    So as you can likely see I am completely stumped over my problem. If anyone has any ideas on what I can do next beside finding some dynamite and blowing the drive up I would appriciate some help.

    Here is a summary of my problems since I have written a great deal.

    -windows would not boot off the drive
    -the bios on my system does see the drive
    -a new install of XP Pro on a second drive doesnt see the other drive through mmc
    -Knoppix can see the drive
    -Mandralinux can also see the drive and can be installed and run off of it
    -fdisk sees the drive but shows an inaccurate size (about 12GB when it is 80GB)
    -Maxtor's PowerMax utility cant see the drive.
     
  2. ravin

    ravin Registered Member

    Joined:
    May 2, 2003
    Posts:
    241
    Location:
    South Carolina
    viper99,

    not sure if ths will help but if you have a sata drive then their is a setting in the bios you need to check for the os to see the drive. can't recall setting offhand but with some looking you'll find it. good luck.
     
  3. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    also try opening up the computer and remove and reattach the cable also recheck the jumper (if the hard drive is ata/ide)
     
  4. Firecat

    Firecat Registered Member

    Joined:
    Jan 2, 2005
    Posts:
    7,927
    Location:
    The land of no identity :D
    More specifically, I'd suggest taking out and re-plugging the cables of the hard drive.

    And also, if you have a SATA drive, you will find an option in the BIOS to enable SATA controller and another option for enabling the SATA Boot ROM. Make sure both these options are enabled.
     
  5. AnthonyG

    AnthonyG Registered Member

    Joined:
    Aug 3, 2004
    Posts:
    614
    Have you went into Manage (by right clicking on the my computer icon on the desktop). Is it showing as there but not assigned or anything.

    As this happend with my Maxtor. It was there on the machine and it showed it was there but windows was not recognising it and it wasnt assigned to anything (i.e I mean C drive etc).

    Also is it the hard drive that came with the machine or is it a new one you have put in, as windows XP does not recognise hard drives over 130GB. Windows XP SP2 does. But if you installed XP normal it could then, i was told, corrupt the data on the hard drive. So you always need to install XPSP2 when first installing XP due to this.
     
  6. VIPER99

    VIPER99 Registered Member

    Joined:
    Jul 4, 2005
    Posts:
    78
    Hey all thanks for the help.

    I finally solve my problem last night.

    I have no idea why the problem occurred in the first place but the reason that windows couldnt see the drive when I was trying to install was that I was installing a pre SP2 XP Pro. Therefore the cd didnt recongnize the sata drive because it wasnt supported.

    I was able to solve the problem by going to the asus site (the manufacturer of my motherboard) and downloading a create sata driver disk. When the XP install was starting I pressed F6 to install additional drivers and got it to install the sata drive controller from the disk. After I did this the Windows XP install recognized the drive and allowed me to install a fresh copy of Windows on the drive.

    Thanks for the help from all who gave it.

    VIPER99
     
Loading...
Thread Status:
Not open for further replies.