Malware Defender v2.3.1 Issue

Discussion in 'other anti-malware software' started by spidey, Jul 26, 2009.

Thread Status:
Not open for further replies.
  1. spidey

    spidey Guest

    xiaolin,

    I wanted to report an issue I am seeing with the latest 2.3.1 version of Malware Defender. I have done some testing and confirmed that the issue does not occur with either the 2.3.0 beta or 2.3.0 final versions that you recently released.

    The issue that I am experiencing is a total system lockup where my only recourse is to reset my computer via the reset button. There is no bluescreen or anything captured in the event log or Malware Defender's logs.

    There are two conditions that cause the system lockup. One is when I am logged in under my SuRunner (created with SuRun) account and launch explorer.exe.

    The other condition occurs when I am logged in as administrator. I am able to launch explorer.exe without a problem, but if I launch Process Hacker and right-click on the previously launched explorer.exe process the system locks up.

    Both of these problems go away if I revert to the 2.3.0 beta or 2.3.0 final versions. I can send you the list of modules loaded with my explorer.exe process if you think that will help you diagnose the problem. I suspect that I may have some program .dll or something loaded by explorer that the new version of MD is tripping over.

    Thanks for all of the support you provide in this forum and for such a great HIPS!
     
  2. xiaolin

    xiaolin Registered Member

    Joined:
    Aug 11, 2008
    Posts:
    248
    I just released Malware Defender 2.3.2 :)

    What's new?
    - Fixed the deadlock problem introduced in version 2.3.1.

    NOTE: I try to fix the physical memory bug in last release, but a new problem was introduced . I revert the code and will fix the physical memory bug later. Sorry for the inconvenience!

    Thanks,
    Xiaolin
     
  3. spidey

    spidey Guest

    Xiaolin,

    Wow that was fast! Xiaolin you are the best. I just got your email about the new release and will give it a try and post back my results.
     
  4. spidey

    spidey Guest

    Xiaolin,

    Got 2.3.2 installed and running smooth. Thanks again! :D
     
  5. G1111

    G1111 Registered Member

    Joined:
    May 11, 2005
    Posts:
    2,127
    Location:
    USA
    Downloaded and running 2.3.2. Running smooth.
     
  6. MagisDing

    MagisDing Registered Member

    Joined:
    Jan 6, 2009
    Posts:
    41
    Maybe it is indeed a flaw(hole) that many safety software has but not a bug IMO:cool: Maybe sandworm fix it in the first place~:rolleyes: Despite of the physical memory "false positive" GJ:thumb:
    Waiting for the next stable version:shifty:
     
    Last edited: Jul 27, 2009
Loading...
Thread Status:
Not open for further replies.