Logon to Panasonic cam

Discussion in 'ESET NOD32 Antivirus' started by Nobel, Dec 7, 2009.

Thread Status:
Not open for further replies.
  1. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    Hi

    I try to connet to a security cam from panasonic, but when I connet
    Internet Explorer 8, has to download a ocx file (active X) from the cam, to show the
    picture.

    But when NOD32 antivirus version 4.0.467 is active I can not see the cam pictures.

    You can try this: http://nbncam.dyndns.tv/CgiStart?page=Single&Language=0

    It continius to say "connecting" and nothing happing. When I disable NOD32 it vorks fine...

    Can this error be fixed ;o)
     
    Last edited: Dec 8, 2009
  2. RyanH

    RyanH Eset Staff Account

    Joined:
    Nov 9, 2009
    Posts:
    64
    Hi Nobel,

    Please provide us with more information:

    Which product are you running and what version?

    Which operating system and version are you running?
     
  3. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    Hi,

    I use, as I have wrote NOD32 Antivirus version 4.0.467.
    Windows XP Pro SP2.

    It is not a unique Panasonic cam that not is working, but all models.
    Have you tried the link to a test cam ?

    Regards
    Nobel
     
  4. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    Hello Nobel,

    I have tried the link you supplied and it worked just fine with 4.0.467 on my machine. I would suggest upgrading to the latest build of the ESET software and if it is still happening, try the procedures below:


    The interruption or difficulty you described may be a result of the Web Access Protection feature.

    1. Open the main program window by clicking the ESET icon next to the system clock or by clicking 'Start' -> 'All Programs' -> 'ESET' -> 'ESET Smart Security' or 'ESET NOD32 Antivirus'.

    2. Press the F5 key to display the Advanced Setup window.

    3. From the Advanced Setup tree, click 'Antivirus and antispyware' -> 'Protocol Filtering'.

    For ESET Smart Security users, click 'Personal Firewall' -> 'Protocol Filtering'.

    4. Select the 'Applications marked as Internet browsers or e-mail clients' option.

    5. From the Advanced Setup tree, click 'Antivirus and antispyware' -> 'Web access protection' -> 'HTTP' -> 'Web browsers' and make sure that only the applications you want scanned with the Internet filter are selected. Typically only real web browsers (iexplorer.exe, firefox.exe, etc.) will need to be selected. Repeat this step for email clients (outlook.exe, thunderbird.exe, etc.) by clicking 'POP3' -> 'Email Clients'.

    6. Click 'OK' to save your changes and then restart your computer.
     
  5. jimwillsher

    jimwillsher Registered Member

    Joined:
    Mar 4, 2009
    Posts:
    668
    Works fine for my on my XP VM with no AV, but does NOT work for me on my Win7 x64 machine with 4.0.474.

    If I have ESET enabled then it sometimes works, sometimes does not. 80% of the time, it does not work.

    Just my 2.
     
  6. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    Hi WayneP

    I have don what you purpose, but I get the same result.

    I can tell you that I before NOD32 antivirus version 4, have used version 2.7 and that, without the problem I have now.

    Thanks jimwillsher for the input.

    It have something to de with the handling of the active X program from the cam, and there are 2 of them, one for the sound, and one for the picture.
     
  7. rockshox

    rockshox Registered Member

    Joined:
    Oct 23, 2009
    Posts:
    261
    This problem didn't start happening about the time you upgraded from IE7 to IE8 did it by any chance?
     
  8. jimwillsher

    jimwillsher Registered Member

    Joined:
    Mar 4, 2009
    Posts:
    668
    I'm on Win7, so IE8 by default.
     
  9. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    Cann't anybody here solve this problem. :oops:
     
  10. bradtech

    bradtech Registered Member

    Joined:
    Nov 16, 2009
    Posts:
    84
    It works good for me in Firefox... In Internet Explorer 8.0 I get the same issues.. I disabled real time protection, and was still getting the issue in IE8..
     
  11. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    I'm having trouble replicating the issue. If you temporarily disable Web access protection will the camera display properly? This would help us narrow down where the issue is coming from.
     
  12. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    Yes If I disable NOD32 antivirus Web access protection, then It works fine and I can see the cam.
     
  13. WayneP

    WayneP Support Specialist

    Joined:
    Apr 9, 2009
    Posts:
    339
    In the Advanced Setup, there is a section under Web access protection called Active mode. If you have your web browser checked in this section, it could cause this type of problem. Check that section and if your browser is listed and has a check in the box, try unchecking it and see if that helps.
     
  14. Nobel

    Nobel Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    7
    I have removed what you describe under Web Access Protection, called the Active mode, but it has not produced a positive result.

    As I have said it's most likely the way NOD32 handles OCX files that are downloaded from the cam.

    There has also been others here who do not can to see the cam I've linked to, so it's not something locally on my computer. This, incidentally all the computers we have in the company where we have NOD32 on, no one can see our security cam, but must disconnect Web protection.
     
  15. rcash

    rcash Registered Member

    Joined:
    Dec 5, 2007
    Posts:
    56
    I had a simular issue with a Panasonic camera we use that uses the BL_Camera.ocx ActiveX and NOD version 4.0.474. I had to add it to the list of addresses excluded from filtering under Advanced Setup tree -> Antivirus and antispyware -> Web access protection -> Http,Https-> Address management.

    I started by checking 'Notify when applying addresses changes from list' and using a broad url such as *nbncam.dyndns.tv* then watched the notices that appeared to narrow it down to a more specific url.
     
  16. LarryV

    LarryV Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    18
    I've had similar issues with a Sony web cam (SNC-RZ25). After installing NOD32 v4 on al PCs at the site initially, they could no longer operate the camera internally. Adding the LAN IP to the list of addresses excluded from filtering under Web Access Protection resolved the issue initially. Did the same thing with the public IP for external users successfully. However, at some point users started complaining again. Turning off Web Access Protection entirely would resolve the issue but excluding the IP would not. Later, it worked as advertised again and now is working without the IP exclusion at all.
    My guess is that various Windows updates are tweaking the way this works and since we have no control over what they do, we're just going along for the ride.
     
Thread Status:
Not open for further replies.