LoadLibrary 1(2,3) failed,error 14001, plugineditrawrule

Discussion in 'LnS English Forum' started by fred22, Mar 3, 2008.

Thread Status:
Not open for further replies.
  1. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    Hi Frederic,

    this error shows up when trying to load the (latest 2.0.0.3) PluginEditRawRule.dll

    after a reboot its LoadLibrary 2 failed,error 14001


    system:
    Win XP SP3 v.3300
    Look'n'stop 2.06


    thanks in advance :)

    **edit**
    i replaced with older 2.0.0.2 and its all good now
    is the 2.0.0.3 for the 2.06p2 only?

    ps: is it recommend/required update 2.06 to 2.06p2
     

    Attached Files:

    Last edited: Mar 3, 2008
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Yes, the version 2.0.0.3 of this plugin is for the 2.06p2 version. However it should have worked anyway with the 2.06 version.

    One reason could be you need to install the VC2005 runtime library, since this DLL was created with this environment (like the 2.06p2).
    Another reason could be you downloaded by mistake the x64 version (but I don't think you would be able to get the version from the property dialog box).

    If you want to use/test some new features (like the rule SPF, and the plugin update is mainly for that purpose), or if you want to have the lastest fixes, yes, it is recommended to update to the 2.06p2.
    All the additions, changes, fixes are in the sticky post.

    Regards,

    Frederic
     
  3. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    Hey Frederic,

    then the problem must be the VC2005 runtime library as i didn't have it installed

    thanks for clearing it up :thumb:

    ps: i'm using Phantom's V8 ruleset, the rule SPF should be placed on top right?!


    thanks anyway :)
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi Fred22,

    Yes, SPF rules should be normally placed on top (or at least on top of the group it belongs to, since usually rules are grouped per protocol; UDP, TCP, ICMP,...).

    Some other rules are probably no longer required (depending on which SPF rules you are using). For instance if you use the DNS SPF rules, standard DNS rules have to be disabled.

    Regards,

    Frederic
     
  5. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    ok, i understand (i think) hehe ;)

    i haven't checked phantom's site in awhile,

    Phant0m``s Look 'n' Stop Ruleset v8 Build: 003 is the one i'm using, this ruleset isn't updated yet for 2.06p2 i guess?

    thx for the help Frederic!


    edit:
    http://www.mntolympus.org/phpbb2/viewtopic.php?t=5007&sid=6b81b09d179d59af047d08f81a093dcc
    any news on this Phant0m?, the latest is still v8 Build: 003
     
    Last edited: Mar 5, 2008
Thread Status:
Not open for further replies.