LNS & Terminal Services

Discussion in 'LnS French Forum' started by fifi, Sep 21, 2003.

Thread Status:
Not open for further replies.
  1. fifi

    fifi Guest

    Bonjour,

    Très bon programme que looknstop.

    Je bute cependant sur un problème.

    Comment éviter le lancement de plusieurs instances de LNS ?

    je m'explique :

    LNS est normalement lancé au démarrage de la machine via une clé de registre :

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "Look 'n' Stop"="\"C:\\Program Files\\Soft4Ever\\looknstop\\looknstop.exe\" -auto"

    Si j'ouvre sur la même machine physique une 2ème session Windows via Terminal Services, une 2ème instance de looknstop se lance, venant perturber le fonctionnement de la 1ère.

    existe t-il une solution ? du style paramètre de lancement ?

    ou faut-il écrire un script de lancement sous vbs ou autre ?

    Avez-vous déjà été confrontés à ce problème ?

    Merci d'avance de vos réponses.

    Philippe.
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    Est-ce que dans le titre de la fenêtre de Look 'n' Stop c'est bien indiqué #1 pour la 2ème instance ?
    Si oui, chaque instance a ses paramètre propres et pour éviter des interférences il suffit de désactiver les 2 filtrages dans les onglets correspondants.

    Ensuite pour éviter que la deuxième instance se lance, s'il s'agit d'un utilisateur différent que celui qui s'est loggé initialement sur la machine, il est possible dans les options de spécifier dans "Base des registres" le choix "Par utilisateur" et normalement dans ce cas, les options de lancement devraient être propres à chaque utilisateur.
    Si c'est le même utilisateur qui se logge, je ne vois pas d'autre solution que juste désactiver la 2ème instance pour éviter les interférence.

    Frédéric
    Chaque instance de Look 'n' St
     
  3. fifi

    fifi Guest

    Merci Frédéric pour cette réponse rapide.

    Effectivement, sur la 2ème fenêtre il est bien indiqué #1 dans la barre de titre.

    L'option registre par utilisateur est bien selectionnée.

    J'ai contourné - temporairement - le problème en supprimant le clé de registre qui lance looknstop, et en lançant le prog manuellement au démarrage de la machine.

    De cette manière tout fonctionne parfaitement....

    Sauf que :

    - si j'oublie de lancer le programme
    - si la machine reboote toute seule (rare, mais possible)

    Je ne fais ni plus ni moins qu'une journée portes ouvertes.... AIE !!

    mon problème doit être isolé, je pense que peu de gens se servent de LNS et terminal services.

    Peut-être qu'un développeur rajoutera une option de lancement de LNS du style "looknstop -unique" qui fera en sorte qu'il soit impossible de lancer le programme plusieurs fois.

    D'ici là je vais essayer d'écrire un script de lancement... et faire des tests plus appronfondis.

    Je communique le résultat en réponse à ce poste.

    Bon courage.
     
Thread Status:
Not open for further replies.