LNS 2.05 b1 - can't get it working with Win XP ICS

Discussion in 'LnS English Forum' started by Jeffrey Edwards, Feb 11, 2004.

Thread Status:
Not open for further replies.
  1. Hi,

    I can't get ICS working with LNS installed. My machine is running XP, the client is running Win 98SE.

    When I uninstall LNS and use the network setup wizard, ICS works fine. However, as soon as I put LNS back on it does not work. Even if I turn off the LNS driver for every network connection it doesn't work. Even if I have LNS not loaded it doesn't work.

    Any ideas?

    Thanks,
    Jeff
     
  2. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    It seems it could be a problem with software itself, I'm not sure however. Did you try reading FAQ's?

    http://www.looknstop.com/En/faq.htm#compatible_ics
    http://www.looknstop.com/En/faq.htm#configure_ics

    And maybe trying to apply specific rule:
    http://www.looknstop.com/En/rules/rules.htm

    I am sure Phant0m`` will be more helpful than I am.

    You might also want to check www.wilderssecurity.info

    regards,

    richter
     
  3. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Thanks richter

    Hey Jeffrey Edwards

    Verify "Keep Internet filtering active after the application is left." feature isn’t enabled with a checkmark, temporary exit out of Look ‘n’ Stop and attempt to connect to your client machines via RUN (\\[Computer-IP]). Do you use or had used Nortons with the current Windows Install?
     
  4. Thanks Richter and Phantom.

    I have read the FAQs, they no special configuration (eg rules) is required for using ICS on XP.

    I will check that feature tonight Phantom.

    Jeff
     
  5. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Do you use Norton Anti-Virus?
     
  6. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    If you had any of their products installed I think you might want to consider running additional cleanup utilities available on their site and also do some manual file searching and registry cleaning afterwards.
     
  7. Jeff E

    Jeff E Guest

    This is a fresh install of XP, I have never had any Norton software on here.

    The "Keep Internet filtering active after the application is left" option was off all along.

    Still does not work. There is no problem with connectivity - both machines can see each other in windows networking and tcp/ip is fine (pinging).

    On the XP machine it does not recognize an internet gateway with LNS installed.

    Arg!
     
  8. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey Jeff E

    Look ‘n’ Stop is packed with two rule-sets, following are;
    StandardRulesSet.rls (Primary)
    EnhancedRulesSet.rls (Secondary)

    If you using EnhancedRulesSet.rls (Secondary) Look ‘n’ Stop rule-set which you should be anyways rather than using Look ‘n’ Stop Primary rule-set, therefore what has been said about no need for a specific ICS server rule doesn’t apply here.

    * Are you using EnhancedRulesSet.rls?
    (Note: If not then you should, see http://www.wilderssecurity.info/0301.shtml for information on switching)

    I would highly recommend creating MAC rules.
    (Note: If you have any troubles don’t hesitate to ask for help)
     
  9. Hi Phantom,

    I am using the EnhancedRulesSet.

    I did create some MAC rules but then removed them when I read that it should work without.

    The fact that it does not work even with the driver unchecked is a concern. I don't understand how LNS could be doing anything with the driver unchecked and the program not loaded.

    Not sure if it is related, but sometimes I have to close LNS to access web sites. If I access the site once with LNS off I can then reload LNS and access the site with no problem. It's seems like LNS is stopping the DNS lookup.

    Getting to the stage where I need to put ethereal on just to see what is happening!

    Regards,
    Jeff
     
  10. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey Jeffrey Edwards

    To disable Look ‘n’ Stop you should always remove checkmark in Internet Filtering screen for “Internet filtering enabled”, or the checkmark for your Network interface shown in Options screen.

    Also you should disable “Automatic selection” if you didn’t so already and check “Common to all users” in Options screen.

    And for Internet Connection problem, that does appear to be DNS server possibly being blocked, you should be able to see logs in the Log screen indicating so. If the problem persists modify the rule named “UDP : Authorize name resolution (DNS)” and switch from “Equal my @” to “ALL” for “IP: Address” drop-list. ;)
     
  11. Hey Phantom,

    ICS still doesn't work after making the changes, and changing the DNS rule as you suggested didn't work either.

    Might go back to 2.04... maybe the beta is buggy for me.

    Otherwise I will have to try a different firewall which is a shame because this is my favourite.

    Thanks,
    Jeff
     
  12. richter

    richter Registered Member

    Joined:
    Jan 3, 2004
    Posts:
    51
    It's beta after all. I do suggest, if you can't get your ICS to work with 2.05 to revert back to latest stable version. I had some problems with LnS, and uninstalling and reinstalling sometimes helps. Tried that?

    regards,

    richter
     
  13. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi Jeff,

    For the DNS related issue, as suggested by Phant0m, it is something with the Internet connection detection.
    When this occurs, could you check if the "Connected to internet" check box is selected on the Welcome page ?

    For the ICS, could you confirm Look 'n' Stop is only installed on the Server ?
    If you deactivated the driver in the Windows options, and it still doesn't work, I suppose the related driver is not lnsfw.sys (packet filter) but the second one lnsfw1.sys (application filter).
    In this case could you try the following:
    - let the driver selected in the Windows options
    - rename lnsfw1.sys in lnsfw1.tmp
    - reboot
    - Look 'n' Stop will report an error but will start anyway without application filtering
    - does it solve the issue ?

    If yes, it is the application filtering that is causing the issue, and I will need the BootLog (with the lnsfw1.sys enabled again) to see what is wrong.

    Frederic
     
  14. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey Jeffrey Edwards

    It would be very useful the log-file, if you didn’t already, enable “Log file” in Look ‘n’ Stop Options screen. If you just enabling it for the first time, reproduce those anomalies and send me the Logs via E-mail Phant0m@wilderssecurity.info
     
  15. Alright! Now I'm getting somewhere (once again thanks to everyone for your assistance).

    I turned on the Log file and turned off Automatically selection. I also uninstalled LNS from the client machine.

    I renamed lnsfw1.sys as suggested by Frederic and rebooted. Lo and behold - ICS now works! Seems like the DNS problem is fixed as well.

    Regarding the lnsfw1.sys file (which is now renamed lnsfw1.tmp), I recall problems with it when I was first installing LNS. There were some blue screens forcing me to restart the machine and pointing to that file.

    Ok, so how can I get application filtering back?

    Thanks,
    Jeff
     
  16. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Rename lnsfw1.tmp back to lnsfw1.sys, re-boot and take window captures of the entire Application Filtering List and send it to Phant0m@wilderssecurity.info . Obviously there is incorrect blockings on Applications which needs to be corrected.
     
  17. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hey Jeffrey Edwards


    In Application Filtering List, remove the deny flag on "Generic Host Process for Win32 Services [SVCHOST.EXE]. :)
     
  18. Jeff E

    Jeff E Guest

    It's all working perfectly now.

    Thanks Phantom (and others), you legend! :D
     
  19. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
Thread Status:
Not open for further replies.