Linux Mint 19.1

Discussion in 'all things UNIX' started by TerryWood, Apr 8, 2019.

  1. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi @ Wilders

    Just installed Mint x64 and booted it. It does not boot up directly, it boots to a black screen with three options:

    1) *Linux Mint 19.1 Cinnamon

    2) Advanced Recovery Options For Linux

    3) System Setup

    After pressing return on 1) it boots up normally.


    How can I get rid of this screen and boot directly into Mint?

    Thank you

    Terry
     
  2. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    Open Terminal...

    sudo xed /etc/default/grub

    In the grub window, edit

    GRUB_TIMEOUT=10

    to

    GRUB_TIMEOUT=0.1

    File, Save. Close the grub window. Ignore any warnings in Terminal. In Terminal...

    sudo update-grub

    Sometimes this is slow. Just wait for the prompt.

    Restart.
     
  3. shmu26

    shmu26 Registered Member

    Joined:
    Jul 9, 2015
    Posts:
    1,353
    That black screen you are seeing is normal and healthy. It is the grub menu. @Brian K told you how to hide it, or bypass it, not sure which is the right word.
     
  4. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K & Shmu26

    Thanks to you both for your kind help.

    I hadn't realised that the black screen was normal as well as a delay before bootup, unless you click return before it automatically boots.

    Brian I tried your suggestion and you explained easily, but when I got the grub window showing I was surprised to see Grub_Timout was already at 0 NOT 10. So I didn't proceed. I've included a copy of the grub window hereunder. Any ideas why?

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    Thanks

    Terry
     
  5. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    Even though you installed Mint over the top of Zorin I think this could be a Zorin leftover. Edit to this...


    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=0.1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX="
     
    Last edited: Apr 9, 2019
  6. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    It looks like the edits have changed since I last did this...

    Make it...

    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0.1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
     
  7. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    Thanks again.

    Tried latest version but it made no difference. Black screen plus 3 options as in my first post.

    Terry
     
  8. fblais

    fblais Registered Member

    Joined:
    Jul 31, 2008
    Posts:
    1,199
    Location:
    Québec, Canada
    You possibly still have the other Linux grub installed.
    In the terminal, type, assuming your HD is sda:

    sudo grub-install /dev/sda && sudo update-grub

    or
    sudo grub-install /dev/sda
    (Grub will be installed to /dev/sda)
    then
    sudo update-grub

    Hope this helps.
    François
     
  9. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    Something I occasionally forget. Did you use...

    sudo update-grub

    ... after the edit?
     
  10. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    Yes I did (include sudo update-grub)

    Again, thanks for your help.

    Terry
     
  11. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    When you open the grub file now, do you see... ( GRUB_TIMEOUT=0.1)

    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0.1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
     
  12. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    Thanks for replying. The answer is yes. See Below

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0.1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    Terry
     
  13. fblais

    fblais Registered Member

    Joined:
    Jul 31, 2008
    Posts:
    1,199
    Location:
    Québec, Canada
    Did you reinstall Grub as I suggested?
     
  14. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi fblais

    I really should have replied to your first response, for which I apologise.

    The truth is I was "windy" about reinstalling Grub. As you probably appreciate I am new to Linux so I am being careful.

    Are there any downsides to reinstalling Grub (Assuming I follow your instructions correctly)?

    Thanks

    Terry
     
  15. fblais

    fblais Registered Member

    Joined:
    Jul 31, 2008
    Posts:
    1,199
    Location:
    Québec, Canada
    None at all.
    It's pretty simple and only takes a few seconds.
    My HD has a few partitions (well, two at the moment), and I test new distros regularly.
    Each install installs Grub, but I prefer to have my main distro's Grub installed.
    So I reinstall Grub on a regular basis. :)
     
  16. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    fblais,

    Do your instructions apply to UEFI and MBR systems?
     
  17. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi @ Wilders

    Brian K & fblais

    Have been doing some further investigation to try and help myself. I have read about a little program called Grub Customizer suitable for Ubuntu and Mint. Information @

    https://www.fosslinux.com/1397/grub-customizer-graphical-interface-to-customize-grub-brug-for-ubuntu-linux-mint-and-elementary-os.htm

    When I opened it up there appear to be two sets of Grub one newer than the other. Since the original installation was Zorin which I had to change to Linux Mint 19, does the two sets of Grub relate to these? I don't understand why it is using Ubuntu in the "List Configuration Tab" instead of say Zorin and Linux Mint,

    Could this be the reason why I cannot stop the Grub screen from appearing?

    I would welcome your input please.

    Thank you


    Terry
     

    Attached Files:

  18. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    Have you run Update Manager and installed all the updates? There have been grub updates since the ISO was released.
    Open Terminal and enter...

    grub-install --version

    Mine is...
    grub-install (GRUB) 2.02-2ubuntu8.13

    What is your grub version?
    Mint is based on Ubuntu so that's why you see "Ubuntu" so often. If you look in the ESP you will see the grub files are in an Ubuntu folder.

    I tried to simulate your situation so I used a computer with a Windows and a Linux multi-boot (UEFI) and installed Mint with the "Erase disk and install Linux Mint" option. On first boot of Mint the grub screen was present but it wasn't present on subsequent boots. I checked "sudo xed /etc/default/grub" and it was the same as yours...

    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    So GRUB_TIMEOUT=10 must only be seen with multi-boots. (All my Linux installs have been in multi-boots)

    Both your screenshots are the same. Your reappearing grub boot screen is a mystery. If you haven't already done so, run Update Manager and see if it helps.

    Edit... Click the Menu button and type Disks. Press Enter. Do you only have two Volumes on the Disk? What is the text in the rectangles? What is the Partition Type of each? (below the rectangles)
     
    Last edited: Apr 11, 2019
  19. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    Thanks again for hanging on in with me.

    Before answering your questions, I should say that in my last post there should only have been one image. The other was a duplicate. I cocked up!

    1) Yes I have used update manager every day. In fact apart from manual, there is an automatic update logo in my systray, which is delivering some form of update nearly every day.

    2) Grub Version - Exactly the same as yours - See Screen Shot.

    3) What does ESP mean and how do I access it?

    4) I "think" the answer to your question is yes. I only have two volumes on the Disk, but to be sure I have sent you a screenshot and hopefully the text will be visible.

    Thanks for your patience.

    Terry GrubScreenshot from 2019-04-12 08-47-21.png DisksScreenshot from 2019-04-12 08-51-45.png DisksScreenshot from 2019-04-12 08-51-45.png DisksScreenshot from 2019-04-12 08-51-45.png DisksScreenshot from 2019-04-12 08-51-45.png DisksScreenshot from 2019-04-12 08-51-45.png
     
  20. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K & Wilders

    Sorry I cocked up again. Multiple uploads of the Disks file.

    Terry
     
  21. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry, can you post a screenshot of Disks with Partition 2 selected?
     
  22. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry, your Partition 2 is a Logical Volume Management partition. Maybe this has something to do with your issue but when I did a test Mint install and enabled LVM I didn't see the grub screen.

    You must have enabled "Use LVM......" when you installed and maybe "Encrypt the.... " as well. I'd avoid both of these options like the plague as they will cause grief in the long run.

    If it was my computer I'd reinstall Mint without Encryption or LVM.

    Edit... ESP is EFI System Partition. You don't have to explore it.

    Nice SSD by the way.
     
  23. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    As requested attached is a screenshot of Partition 2

    As far as I know I did not enable encryption but it looks as though I enabled LVM.

    If I reinstall Mint which install should I go for?

    What about fblais's suggestion is it worth trying and is there a risk?

    Also I include a screenshot from another forum suggesting removing the word "Splash". What do you think?

    Thanks for your help

    Terry Partition2Screenshot from 2019-04-12 12-18-13.png RemoveSplash.png
     
  24. Brian K

    Brian K Imaging Specialist

    Joined:
    Jan 28, 2005
    Posts:
    10,341
    Location:
    NSW, Australia
    Terry,

    Fblais' suggestion is good but I'm waiting for him to get back to us if it applies to both MBR and UEFI systems. I have different lines for a UEFI grub re-install.

    To reinstall Mint, use the same method you just used. Early in the install there is a page about installing Third Party software. Don't put a tick in that box.

    On the Install screen, don't tick LVM.

    Thanks for the screenshots. I've no idea about the "splash" one. It's possible reinstalling Mint will fix the grub boot screen. I hope so. But getting rid of the LVM partition would be my first interest.
     
  25. TerryWood

    TerryWood Registered Member

    Joined:
    Jan 14, 2006
    Posts:
    837
    Hi Brian K

    Thanks for the reply. A couple of points.

    1) "But getting rid of the LVM partition would be my first interest." How do we do this? Do I hang on, I would prefer not to re install because I have made a lot of progress in setting up Mint and so far I am very happy?

    2) I notice on my boot menu a couple of entries and I quote:

    a) Ubuntu (Patriot Scorch M2)

    b) Patriot Scorch

    Why are there two entries for the SSD (I assume it's the SSD)

    Thanks

    Terry
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.