Latest Firefox 17.0.1 crashing on Flash content

Discussion in 'other software & services' started by wat0114, Dec 2, 2012.

Thread Status:
Not open for further replies.
  1. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,984
    Location:
    Canada
    Is anyone experiencing this? I first noticed last night using Lubuntu, but it's happening again under Win 7. Soon after I ran the update, Firefox won't display Flash content and freezes solid, requiring a kill using Process explorer.
     
  2. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,984
    Location:
    Canada
    Strange, it's working again under Windows. I had it running @ low il, removed them to revert to default medium il, then it worked, put it back to low il and it continues working just fine. Puzzling, and it was the same crashing as happened on Lubuntu while I was building an Apparmor configuration for Firefox. It was in complain mode so it wasn't that causing the crashes on Flash content.
     
  3. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    ABP List(s) ? Do you have hardware accelertion enabled ?
     

    Attached Files:

  4. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,047
    Location:
    USA
    Mine has been crashing. I have not investigated as to the why. I keep trying to use Firefox less but end up using it anyway. :doubt:
     
  5. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,984
    Location:
    Canada
    Yes, I always have. Is this supposed to help or can it contribute to the crashing?

    It's never crashed on me like this before until this latest version. I like FF because of NS plus I can run it @ low il, which in turn forces Flash and Java to low il as well.
     
  6. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    H/W Acceleration should be enabled if:
    For GPU challenged PC's, this may be the case. I see no difference with acceleration on | off .

    Possibly too many ABP subscriptions, assuming you use ABP.
     
  7. vasa1

    vasa1 Registered Member

    Joined:
    May 1, 2010
    Posts:
    4,152
    But wouldn't you have different versions of Flash? The plug-in for Linux has just "security" fixes, IIRC.

    BTW, I recently built my own Apparmor profile for Firefox (beta) on Lubuntu 12.10 but the Firefox I built it for is direct from Mozilla and not the one modified by Canonical. And I installed it in my home folder.

    In your other posts, you haven't mentioned installing "auditd". If you do install it, Apparmor messages will be in /var/log/audit/audit.log and nowhere else. I would guess that whether you rely on logprof or eyeball the log itself, it maybe simpler.
     
  8. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    3,768
    Location:
    Nicaragua
    Hi Wat0114, a few months ago some users had their Firefox crash and freeze after Flash players protected mode was introduced. Disabling it might fix your problems. Flash and Firefox are working fine for me.

    http://www.ghacks.net/2012/06/10/flash-player-update-fix-freezes-crashes-in-firefox/

    http://forums.adobe.com/thread/1018071

    Bo
     
  9. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,984
    Location:
    Canada
    You're probably right, It's something I didn't check, but since the brief hicups earlier in the day, it's been working fine under Windows. I've the same problem now under Xubuntu on a different machine. So the problem is now only happening under Linux.

    I just build my own from scratch, but Flash pages started freezing with the profile still in complain mode, and even after I disabled the profile and removed it, so it's definitely not Apparmor-related.

    Thanks, but I would rather not go this route, especially since it's only just started happening to me with this latest release.

    @siljaline,

    I tried disabling both NS and AdBlock+ plugins but that didn't help. Also problem still happens whether hardware accelleration is enabled or not.

    Thanks everyone for the suggestions :)
     
  10. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    You're welcome for the comments. I'm a bit low on the Mozilla learning curve but that's not to say that I don't know some tweaks.
     
    Last edited: Dec 3, 2012
  11. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Even with ABP, etc, enabled, sites with too much malvertising will overwhelm the Browser, causing it to temporarily crash.
     
  12. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,047
    Location:
    USA
    There is a definite issue with 17.01. I am still using the same add-ons and settings as with all other builds and it is crashing on 2 machines. I'm running the 18 beta 2 on a third machine, no issues. Maybe I'll just update them all.
     
  13. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,047
    Location:
    USA
    I just realized that as of version 17 that hardware acceleration is disabled for ATi/AMD drivers older than 12.8, at least on Windows 8. Since a lot of people like myself have "legacy" cards (4000 series or older) there are no drivers newer than 12.6. Firefox 16.02 was working just fine. I'm not very pleased with what they are doing to Firefox these days. :mad:
     
  14. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    It's a PITA that many are now struggling with sluggish Browsers while Mozilla are busy pushing Facebook plug-ins. Experimenting with H/W Accel on | off.
     
  15. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Last edited: Dec 7, 2012
  16. luciddream

    luciddream Registered Member

    Joined:
    Mar 22, 2007
    Posts:
    2,497
    Could you please clarify exactly where this setting is that shows you that?

    For what it's worth, I'm using v 17.0.1 with no problems. On XP Pro SP3 (32-bit), and with the latest version of Adobe Flash (11.5.502.110).

    And as long as that Facebook crap remains opt-in I'm okay with it. I've deleted the values (URL's) for them in about:config altogether.
     
  17. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    4,047
    Location:
    USA
    Type about:support in the address bar and scroll down to the graphics section. If it is disabled it will tell you why.
     
  18. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    3,768
    Location:
    Nicaragua
    Same here.

    Also in W7 32bits.

    Bo
     
  19. luciddream

    luciddream Registered Member

    Joined:
    Mar 22, 2007
    Posts:
    2,497
    Not only is it running fine, it boots noticeably quicker. Before, whenever using FF sandboxed, it took about 3 seconds longer for it to boot than unsandboxed. Now it opens just as quickly sandboxed... practically immediately. I noticed it after upgrading to v 17.

    When I go into about:support, under Graphics, I see: "GPU accelerated windows", with the value "0" to the right of it. That's all. I'm using a Dell Dimension 3000 with integrated graphic controller dated 2005... no surprise there. Everything is very snappy though the way it is.

    Perhaps this is one of those changes that benefits users with older/lower spec setups, and punishes those with newer/higher end ones?
     
  20. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    I had promised follow-up to this thread https://www.wilderssecurity.com/showpost.php?p=2155093&postcount=31

    Regarding the comments on your Browser dictating your GPU settings in lieu of system defaults, I strongly disagree.
    If Mozilla maintains this position, I will continue to disagree with this position.
    Graphics hardware rendering should not be at the mercy of your default Browser.
     
  21. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    1,984
    Location:
    Canada
    I can confirm now it is Apparmor killing Flash in Firefox, and it happens while I'm profiling Firefox, still in complain mode, right after I create a profile for the plugin-container. Apparmor needs to be disabled and the Firefox and associated profiles removed, then reboot to fix the problem. The latest attempt is on mint 14 xfce x64.
     
Loading...
Thread Status:
Not open for further replies.