KMS blargh

Discussion in 'all things UNIX' started by Gullible Jones, Feb 12, 2010.

Thread Status:
Not open for further replies.
  1. Is anyone else getting the problems I am with Intel kernel modesetting in various up-to-date distros?

    I get:

    - Random GPU crashes (mouse works but GUI won't respond)
    - Xorg going into an endless loop when I plug in an external monitor
    - Very fast screen flickering every few minutes
    - The screen going blank (well, all one color) on random events, e.g. clicking a menu
    - Mad cursor skipping and freezing when there's any CPU activity, probably indicative of CPU spikes
    - Generally poor performance

    Disabling KMS (via i915.modeset=0) solved every single one of these problems. Unfortunately KMS is now required for the latest Intel driver; disabling it will make X fail to start. So the old solution... no longer works.

    Does anyone here know any way around these issues? If so, please tell me, I'm dying to get rid of Windows XP and its impending obsolescence.

    BTW, in case anyone wants to suggest using CentOS or Ubuntu LTS - I would, but I'm using an Eee 1005HAB netbook that needs a newer kernel. Most notably, the ethernet card will suffer a firmware crash on kernels older than 2.6.31, requiring a cold boot to work properly again. And the wifi is ath9k, of a variety not supported by older drivers and that dislikes ndiswrapper.

    So, thanks in advance for any tips... o_O
     
  2. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    KMS on Karmic works fine here with my SONY Vaio laptop, far better than it did in Intrepid and Jaunty.
     
  3. FIXED! Or so it seems anyway!

    Amusingly the fix seems to consist of disabling my old enemy HAL. With input hotplugging disabled and HAL out of the way, XOrg has neither crashed nor flickered. Yay.
     
  4. ... Nope, no good. Screen still flickering. Blargh.

    Edit: Okay it's fixed for real this time. Anyone else getting this problem, try adding "i915.powersave=0" to the kernel options in GRUB or LILO. Not sure of the side effects (shorter battery life?) but it seems to work.
     
    Last edited by a moderator: Feb 14, 2010
  5. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Thats for disabling GPU power savings, it shouldn't make much of a difference.
     
Thread Status:
Not open for further replies.