iTunes 9 Home Sharing Fail

Discussion in 'ESET Smart Security' started by Wing Fat, Sep 11, 2009.

Thread Status:
Not open for further replies.
  1. Wing Fat

    Wing Fat Registered Member

    Joined:
    Jul 13, 2007
    Posts:
    3
    I'm trying to use the new "Home Sharing" feature of iTunes 9. I followed the instructions but could not get it to work. Finally I disabled the firewall in Smart Security and Home Sharing worked fine. When I rebooted (and re-enabled the firewall) Home Sharing stopped working again.

    Does anyone know how to get this to work? I found this on the Apple support forum (support.apple.com/kb/TS2972); under "Firewall Settings" it says:

    --------
    If you have a firewall enabled in your router or computer, make sure that the firewall is not blocking communication between your computers. Home Sharing uses TCP port 3689 and UDP port 5353 to communicate with other copies of iTunes.

    For Mac OS X 10.5 or later, you don't have to edit the port addresses, but make sure the firewall in Apple menu > System Preferences > Security > Firewall are not set to:

    * Block all incoming connections
    * Allow only essential services

    If you use another operating system, firewall software, or hardware, check the documentation on how to open TCP port 3689 and UDP port 5353.
    --------

    I'm not sure how to do any of the above. I am using Windows XP with Smart Security 4 on both computers I am trying to share. I have the firewall set to "automatic mode."
     
  2. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,764
    Location:
    Texas
  3. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
Thread Status:
Not open for further replies.