Is this normal of appdefend?

Discussion in 'Ghost Security Suite (GSS)' started by dja2k, May 10, 2006.

Thread Status:
Not open for further replies.
  1. dja2k

    dja2k Registered Member

    Joined:
    Feb 15, 2005
    Posts:
    2,040
    Location:
    South Texas, USA
    I noticed today for the first time since using appdefend that it was geting close to 70 + MB of usage because of the log getting too big due to using a p2p program dealing with all the connections allowed. Is this normal behavior?

    dja2k
     
  2. gottadoit

    gottadoit Security Expert

    Joined:
    Jul 12, 2004
    Posts:
    601
    Location:
    Australia
    dja2k,
    In order to stop this behaviour you need to stop logging the connections for the application
    Alternately you could exit the GUI every now and again which will empty out the Log tab (and all the entries using the memory).

    When you exit the GUI the rules that are in place (inside the kernel driver) will continue operating as normal, except for the "Ask User" alerts (which will either block or be allowed depending on the rules used). Because of this it isn't really problematic if you wanted to periodically exit and restart the GUI and keep your logging enabled

    It isn't ideal at the moment but it is something that will happen with every application that hasn't written their own custom listview or hasn't taken steps to show fewer entries from the log in the listview at any one time

    Hope this helps
     
  3. dja2k

    dja2k Registered Member

    Joined:
    Feb 15, 2005
    Posts:
    2,040
    Location:
    South Texas, USA
    Yeah thanks for the response. I figured that last night to turn GSS off and then back on and both gss.exe's dropped to about 3 MB's.

    dja2k
     
  4. f3x

    f3x Registered Member

    Joined:
    Feb 6, 2006
    Posts:
    311
    Location:
    Montreal, Quebec
    p2p and firewall never goes well together.
    You figured out how to clear cache of logging wich is a good temporary solution.
    A better long term solution is to
    1) Select the app in the appdefend tab
    2) Uncheck the checkbox near to network configuration.

    You do not need to log every single connection your p2p client makes as it does many. Emule makes about 4 connection per second or more.

    I know gottadoit suggested it to you also but you only answaer you figured about the on/off wich i consider as a patch rater than a fik.Gss seams not optimised for that many logs.
     
Thread Status:
Not open for further replies.